Download it now!
Bug 114806 - Very slow load of single page draw file
Summary: Very slow load of single page draw file
Status: RESOLVED DUPLICATE of bug 83426
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-02 15:56 UTC by bugzilla
Modified: 2018-01-04 09:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample draw file that exhibits reported problem (107.62 KB, application/vnd.oasis.opendocument.graphics)
2018-01-02 15:58 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2018-01-02 15:56:49 UTC
Description:
Draw file takes ~3 minutes to load. Processor is pegged (1 CPU on a quad core)  during whole load time. Application is unresponsive.

Steps to Reproduce:
1.Try to load attached draw file.
2.Wait
3.Wait some more

Actual Results:  
3 minutes+ to load file

Expected Results:
< 5 seconds to load file


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Also occurs on earlier versions, 32 or 64 bit. 


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36
Comment 1 bugzilla 2018-01-02 15:58:41 UTC
Created attachment 138810 [details]
Sample draw file that exhibits reported problem
Comment 2 Jean-Baptiste Faure 2018-01-02 18:11:15 UTC
The problem seems to comes from the repeated svg image. Interpreting svg language is always CPU consuming. You should convert this image in png format. I did that by compressing the first svg image (right click then compress) then copying the resulting png image in place of others. The new file is only 40 kB and is opened in only 1 second.

That said, before opening a bug report, you should have ask for help on users mailing list.

Closing as NotABug. Feel free to reopen if you disagree.

Best regards. JBF
Comment 3 bugzilla 2018-01-03 08:49:44 UTC
Jean-Baptiste,

Thank you for the comments, and while it has resolved the problem with this file, I still believe this is not acceptable performance. There are 12 copies of an identical SVG in the sample file, and 3 minutes on a reasonably fast processor (Intel i5) still appears to me to be poor. 

At the very least, Libreoffice should be displaying progress while it processes the images - and I believe this behaviour would also occur in Impress as well as Draw (and probably anywhere else where SVG files could be processed).

I've reopened the bug, but reduced its importance to "minor".
Comment 4 Telesto 2018-01-03 15:57:56 UTC
Probably bug 83426 or bug 101682 (full list of known issues: https://bugs.documentfoundation.org/showdependencytree.cgi?id=99825&hide_resolved=1)
Comment 5 Xisco Faulí 2018-01-04 09:54:31 UTC

*** This bug has been marked as a duplicate of bug 83426 ***