Bug 114836 - FILEOPEN: Chart height is different than before
Summary: FILEOPEN: Chart height is different than before
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:6.3.0 target:6.1.4 target:6.2.0.1
Keywords: bibisected, bisected, regression
: 117705 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2018-01-04 17:14 UTC by Xisco Faulí
Modified: 2019-05-02 09:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (46.75 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-01-04 17:14 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.1 (91.01 KB, image/png)
2018-01-04 17:15 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-04 17:14:08 UTC
Created attachment 138877 [details]
sample

Steps to reproduce:
1. Open attached document
2. Check the chart. it's an ellipse instead. See the image attached

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-01-04 17:15:02 UTC
Created attachment 138878 [details]
comparison MSO 2010 and LibreOffice 6.1
Comment 2 Xisco Faulí 2018-01-04 17:17:35 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2017-12-13 22:03:12 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2017-12-18 12:37:41 +0100
commit	e1697600253361a26d77a1ef61f8bde16af0ed2c (patch)
tree	533a2baeea5a71b6977d90d63f71d986c8394d73
parent	beb091666aa325376b4ad6d1ff68c7c3ae82fcd4 (diff)
chart2: Batch changes to properties when creating 3D objects
MultiPropertySet doesn't broadcast ItemSets as often as setting
each property separately. This can help when we create a lot of
3D objects.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tomaž Vajngerl
Comment 3 Xisco Faulí 2018-01-29 11:56:58 UTC
attachment 94196 [details] from bug 74111 is also affected.
Comment 4 Aron Budea 2018-10-28 04:25:19 UTC
*** Bug 117705 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2018-10-28 04:28:12 UTC
An ODT example from bug 117705: attachment 142205 [details]

The change to impl_createCube(...) is what results in the different behavior, but the actual cause must be elsewhere, perhaps in how MultyPropertySet is handled for the shape vs PropertySet.
Comment 6 Markus Mohrhard 2018-11-23 00:25:13 UTC
The Shape UNO API implementation for the XMultiPropertySet::setPropertyValues implementation was a bit problematic. Instead of only changing the properties for the few properties that were actually set, the implementation was always setting every single property again. This led to some slightly different calls than by calls to XPropertySet::setPropertyValue.

I have a fix that actually changes the behavior of the XMultiPropertySet::setPropertyValues to only set the changed properties.
Comment 7 Commit Notification 2018-11-23 07:01:14 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/80cf278d365a2d357c70b8c28947c91fa97e7a99%5E%21

tdf#114836, only set changed SfxItemSet properties

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-11-23 09:36:23 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/b3af23568f9b9b444ae09f2a1ab4a61d212b422a%5E%21

tdf#114836, only set changed SfxItemSet properties

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-11-23 09:36:32 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d4190685ac208677bc77f66976287dda0360c42d%5E%21

tdf#114836, only set changed SfxItemSet properties

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-11-26 13:17:18 UTC
Verified in

Version: 6.2.0.0.beta1+
Build ID: a63cd8bbe7cf881daa8dc7a7f32f3e5ac384e902
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Markus Mohrhard, thanks for fixing this!!