Download it now!
Bug 114860 - ODS mixes style with conditional formatting and direct formatting
Summary: ODS mixes style with conditional formatting and direct formatting
Status: CLOSED DUPLICATE of bug 117715
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2018-01-06 12:39 UTC by popxunga
Modified: 2019-10-26 19:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Spreadsheet (31.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-01-06 17:33 UTC, popxunga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description popxunga 2018-01-06 12:39:03 UTC
Description:
The provided spreadsheet doesn't work properly on 5.4.4.2 and 6.0.0.1 versions.
However it works fine on 5.0.6.2.

Steps to Reproduce:
1.Just open the spreadsheet.
2.In each month, the cell for the days greater than the last day of the month should be empty.

Actual Results:  
When opened with versions 5.4.4.2 and 6.0.0.1 some cells after the last day of each month, show a value when in fact they should be empty.

Expected Results:
The result seen when open the spreadsheet with 5.0.2.6.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Get spreadsheet from here: _https://files.fm/u/3xgx46h4


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 MM 2018-01-06 13:19:08 UTC
Could you provide a test file, so we can test ?
If so, change the status field back to unconfirmed.
Comment 2 popxunga 2018-01-06 17:33:11 UTC
Created attachment 138921 [details]
Test Spreadsheet

I've included an url in my 1st report, but here you have the file.
Comment 3 raal 2018-01-06 19:17:33 UTC
I can confirm with Version: 6.1.0.0.alpha0+
Build ID: 88f6ffeb9e0c0b942c2b0bc9d60af7bb7a6caaf8
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 4 Telesto 2018-01-06 19:25:41 UTC
Found in
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (nl_NL)

Windows is also affected -> Setting to Hardware ALL
Comment 5 Xavier Van Wijmeersch 2018-01-07 09:27:36 UTC
I did look to another perpetual calendar and i found that the latest 10 cells of the month did have another formulae: as a example this one

=IF(EOMONTH(DATE(Anno;SHEET()-1;1);0)<G20+1;"";G20+1)

so in your test file in cells b10 to h11: also for the other month's; there is the need of another formulae and the problem will be gone
also you change your cf for column AC and AD: "AC5:AD38" this will do the formatting and remove the others

Best regards
Comment 6 raal 2018-01-09 15:11:13 UTC
This seems to have begun at the below commit.
Adding Cc: to XXXX ; Could you possibly take a look at this one if it's bug or not? Thanks

da7753060ea125a2bdf21e7af87367142ae59467 is the first bad commit
commit da7753060ea125a2bdf21e7af87367142ae59467
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Apr 2 21:31:18 2016 -0700

    source sha:2c728b0ae7f52691b1a3d5ab555225f5e8ac95a5

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-02-03 20:28:40 +0100
committer	Eike Rathke <erack@redhat.com>	2016-03-31 16:13:52 +0000
commit	2c728b0ae7f52691b1a3d5ab555225f5e8ac95a5 (patch)
tree	879ced4a17952e3e95ae77a95bfa66dc81a5a2be
parent	eaced256be7e5c2ebcea01d14b2f521629e22848 (diff)
tdf#93300, handle hard formatting with cond format correct
Comment 7 QA Administrators 2019-01-11 03:53:53 UTC Comment hidden (obsolete)
Comment 8 Timur 2019-01-11 10:47:46 UTC
LO 6.3+ behaves as described. 
FWIS, cell B11 applies style cf24 with user-defined format [>0]"";[<0]"";"" while direct format is date "D".
What I don't get is why cell B11 shows direct format and C11 not.
Comment 9 Eike Rathke 2019-10-26 19:18:01 UTC

*** This bug has been marked as a duplicate of bug 117715 ***