Download it now!
Bug 114875 - Don't show "No offline help installed" popup again
Summary: Don't show "No offline help installed" popup again
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Nickson Thanda
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Help-Msgbox
  Show dependency treegraph
 
Reported: 2018-01-07 01:28 UTC by Clemens Prill
Modified: 2019-08-28 14:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Prill 2018-01-07 01:28:32 UTC
Description:
I would like to see an option to always open online help if there is no offline help installed without this annoying pop up.

Steps to Reproduce:
Press help button, for example in Update LibreOffice dialogue

Actual Results:  
No offline help installed pops up

Expected Results:
Set a tick or some LibreOffice option so I don't see this pop up ever again (only once), if there is no offline help installed


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Thomas Lendo 2018-01-10 21:55:22 UTC
Solution 1:

A solution would be a remember-the-choice question with a checkbox in the dialog.

A checkbox in Tools > LibreOffice > General > Help could be added to set/unset this check mark if the user wants to set his/her choice back.

Solution 2:

Only the first time in a LibreOffice session the not-installed dialog appears.
Comment 2 Yousuf Philips (jay) (retired) 2018-01-10 22:47:32 UTC
(In reply to Thomas Lendo from comment #1)
> Solution 2:
> 
> Only the first time in a LibreOffice session the not-installed dialog
> appears.

+1
Comment 3 Heiko Tietze 2018-01-11 03:48:30 UTC
(In reply to Thomas Lendo from comment #1)
> Solution 1:
> 
> A solution would be a remember-the-choice question with a checkbox in the
> dialog.
> 
> A checkbox in Tools > LibreOffice > General > Help could be added to
> set/unset this check mark if the user wants to set his/her choice back.

+1 

(Because we don't urge the users to remember every choice have been made. Furthermore the option to revert the decision is needed anyway, meaning tools ... > help is mandatory.)
Comment 4 Mike Kaganski 2018-01-11 06:53:15 UTC
(In reply to Thomas Lendo from comment #1)
> Solution 1:

+1
Comment 5 Adolfo Jayme 2018-06-04 04:27:13 UTC
(In reply to Heiko Tietze from comment #3)
> (Because we don't urge the users to remember every choice have been made.
> Furthermore the option to revert the decision is needed anyway, meaning
> tools ... > help is mandatory.)

That doesn’t need to be an extra check box; it could be a setting in Expert Configuration. This directly runs counter-intuitive to our effort to simplify the Options pages.
Comment 6 Commit Notification 2018-06-11 12:50:11 UTC
Nickson Thanda committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=175a1d13adce55bb4411209736bb332aab990f9c

tdf#114875 Added an option to not show "No offline help installed" popup

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Heiko Tietze 2018-07-19 13:20:18 UTC
Works as expected, though this dialog is terribly ugly. Center aligned headline, text (title, secondary_text) and checkbox makes no sense.