Download it now!
Bug 114881 - Creating files from File > Wizards > Agenda crashed
Summary: Creating files from File > Wizards > Agenda crashed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:6.1.0 target:6.0.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-01-07 12:41 UTC by Franklin Weng
Modified: 2018-03-02 19:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash after clicking Finish in the Agenda wizard (115.54 KB, image/png)
2018-01-07 12:41 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2018-01-07 12:41:04 UTC
Description:
LibreOffice crashed everytime I try to create a file from File > Wizards > Agenda

Steps to Reproduce:
1. Open LibreOffice start center or any applications
2. Choose File > Wizards > Agenda
3. Fill every data from step 1 to 6 and click Finish
4. LibreOffice crashed (as attached image)

Actual Results:  
LibreOffice crashed

Expected Results:
It should create an agenda document


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36
Comment 1 Franklin Weng 2018-01-07 12:41:54 UTC
Created attachment 138938 [details]
Crash after clicking Finish in the Agenda wizard
Comment 2 Franklin Weng 2018-01-07 12:47:37 UTC
It also crashed when I tried to choose the path of the template file.

LibreOffice 5.4.4.2 works.
Version: 5.4.4.2
Build ID: 1:5.4.4~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: zh-TW (zh_TW.UTF-8); Calc: group


LibreOffice 6.0.0.1 failed.
Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: zh-TW (zh_TW.UTF-8); Calc: group
Comment 3 Julien Nabet 2018-01-07 16:05:07 UTC
On pc Debian x86-64 with master sources updated some days ago, I don't reproduce this.

I let all the fields blank to test this quickly, could you indicate what to put on each field to reproduce this?
Comment 4 Jean-Baptiste Faure 2018-01-07 16:47:37 UTC
Set status to NEEDINFO from comment #3, please set it back to UNCONFIRMED once requested informations are provided.

Best regards. JBF
Comment 5 MM 2018-01-07 20:30:44 UTC
Confirmed on window 7 x64 with Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 3; OS: Windows 6.1; UI render: default

Confirmed on windows 10 x64 with Version: 6.0.0.1 (x64)
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: 

Step 3 isn't necessary, just press finish and try to save a file.
Comment 6 MM 2018-01-07 20:36:04 UTC
Also crashes with Letter & Fax Wizard.
Just start the wizard, press finish and try to save a file. Crash...
Comment 7 Jean-Baptiste Faure 2018-01-08 08:08:22 UTC
Not reproducible for me with LO 6.0.0.1.0+ built at home under Ubuntu 16.04 x86-64 :
Version: 6.0.0.1.0+
Build ID: bd04d7be1f89600623c148a7837a694c1df388d7
Threads CPU : 4; OS : Linux 4.4; UI Render : GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

Best regards. JBF
Comment 8 Franklin Weng 2018-01-08 11:43:42 UTC
I tried to run on gdb and when it crashed I got the backtrace here:

https://pastebin.com/us0KfqWX

In my another slimbook I built libreoffice 6.1alpha from git and this problem didn't show.

Do you have a version with debugging symbols so that I can get a better backtrace for you?
Comment 9 Xisco Faulí 2018-01-08 11:50:25 UTC
It doesn't crash for me, but I get this backtrace in the console:

Traceback (most recent call last):
  File "/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/wizards/fax/FaxWizardDialogImpl.py", line 368, in saveConfiguration
    self.myConfig.writeConfiguration(root, "cp_")
  File "/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/wizards/common/ConfigGroup.py", line 30, in writeConfiguration
    self.writeField( name, configurationView, param)
  File "/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/wizards/common/ConfigGroup.py", line 37, in writeField
    prefix)
  File "/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/wizards/common/ConfigGroup.py", line 30, in writeConfiguration
    self.writeField( name, configurationView, param)
  File "/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/wizards/common/ConfigGroup.py", line 39, in writeField
    setattr(configView,propertyName,getattr(self,field))
uno.com.sun.star.beans.UnknownPropertyException: IntrospectionAccessStatic_Impl::setPropertyValueByIndex(), property at index 18 is readonly


Version: 6.1.0.0.alpha0+
Build ID: 0ef0740298b45379bbf8d00d50beffee7a2f812a
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 10 Xisco Faulí 2018-01-08 12:32:40 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 864ab0502a4d3506413451e8c545144c6c15d777
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-28_00:54:35
Locale: es-ES (es_ES); Calc: group threaded
Comment 11 Xisco Faulí 2018-01-08 12:35:04 UTC
The backtrace in comment 9 points me to:

author	Stephan Bergmann <sbergman@redhat.com>	2017-09-05 17:57:18 +0200
committer	Stephan Bergmann <sbergman@redhat.com>	2017-09-05 17:57:18 +0200
commit	cb2550750386f51ef7a46a8a664a4ab9de614f8d (patch)
tree	aabfee7b4e12074f4ed6f80e8f2f5101d284385e
parent	e808bbe1ce51465e6f3e9dc4fec2ecd263fe0e4b (diff)
Drop lazywrite property, which is silently ignored by configmgr anyway
...at least ever since the "new" configmgr reimplementation,
6b849a6aeeb9ea8b1e25e28d5a8be390e425f84e "#i101955# initial work in progress of
a configmgr reimplementation (for now in an extra module 'configmgr2')" et al

Bisected with: bibisect-linux64-6.0

Adding Cc: to Stephan Bergmann
Comment 12 Xisco Faulí 2018-01-08 14:49:23 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/47600/
Comment 13 Chavdar 2018-01-08 20:13:42 UTC
Not reproduced 

Version: 6.0.0.1 (x64)
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: bg-BG (bg_BG); Calc: group
Comment 14 Commit Notification 2018-01-08 22:24:48 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f9aea0c1aa77a88a3dbfcc668dc410f983f3460

tdf#114881: Re-introduce ConfigurationUpdateAccess

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-01-09 14:06:34 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a51cb7fb81139f5f8f013c53a154078ef36032f0&h=libreoffice-6-0

tdf#114881: Re-introduce ConfigurationUpdateAccess

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.