Download it now!
Bug 114904 - Command to remove list formatting from text
Summary: Command to remove list formatting from text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UNO-Command-New Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2018-01-08 10:20 UTC by Thomas Lendo
Modified: 2018-01-17 20:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-01-08 10:20:40 UTC
When having an unordered or ordered list, you can remove it with Format > Bullets and Numbering... > Remove.

It would be helpful to have this command in the Customize dialog to include it in menus, context menus, etc. or to assign it to a keyboard shortcut.
Comment 1 Heiko Tietze 2018-01-09 08:18:01 UTC
Reasonable request, if not filed before.
Comment 2 Yousuf Philips (jay) (retired) 2018-01-09 18:28:50 UTC
This is already available by untoggling the set bullet or numbering list in the formatting toolbar or Format > List > Bulleted/Numbered List.
Comment 3 Thomas Lendo 2018-01-09 22:18:41 UTC
Jay, I disagree. All these possibilities are not obvious to the users I know.

Also I'm searching for a command to use such "list deletion" in a similar way like the "Clear direct formatting" command in the styles formatting toolbar.
Comment 4 Yousuf Philips (jay) (retired) 2018-01-10 18:36:37 UTC
(In reply to Thomas Lendo from comment #3)
> Jay, I disagree. All these possibilities are not obvious to the users I know.

Not sure how it isnt obvious to users that when a button is in its toggled state, that the feature is on and when untoggling it, the feature is removed. This is a common behaviour found in most of the toggle buttons found the formatting toolbar like bold, italics, superscript, etc.

> Also I'm searching for a command to use such "list deletion" in a similar
> way like the "Clear direct formatting" command in the styles formatting
> toolbar.

See bug 101965.
Comment 5 Thomas Lendo 2018-01-10 23:19:43 UTC
(In reply to Yousuf Philips (jay) from comment #4)
> (In reply to Thomas Lendo from comment #3)
> > Jay, I disagree. All these possibilities are not obvious to the users I know.
> Not sure how it isnt obvious to users that when a button is in its toggled
> state, that the feature is on and when untoggling it, the feature is
> removed. This is a common behaviour found in most of the toggle buttons
> found the formatting toolbar like bold, italics, superscript, etc.
The toggle list button isn't available in the style formatting toolbar. And in the discussion about removing the x to close the sibdebar decks/tabs it was noted that the toggling behavior of the tab buttons isn't obvious. Same here from my point of view. Lists are a completely different feature compared to direct formatting controls like bold or superscript.

> > Also I'm searching for a command to use such "list deletion" in a similar
> > way like the "Clear direct formatting" command in the styles formatting
> > toolbar.
> 
> See bug 101965.
Interesting, thanks. But there is no command suggested, only new list entries, etc. what doesn't help in toolbars/Notebookbars.
Comment 6 Mike Kaganski 2018-01-13 09:22:30 UTC
I see that some consistently mark issues "RE SOLVED WORKSFORME" when it's not an appropriate resolution. Another example is bug 103705 (currently it's OK, but you may look at history to see that).

WORKSFORME is only applicable for bugs that were actually present in versions where they were reported, and later they were fixed, but specific commit is unknown. If an issue is desided to be absent where it was reported - like here - then it's NOTABUG or INVALID.
Comment 7 Thomas Lendo 2018-01-13 09:52:23 UTC
Set back to Unconfirmed, awaiting a second opinion that says either New or Invalid.
Comment 8 Yousuf Philips (jay) (retired) 2018-01-14 15:03:27 UTC
(In reply to Thomas Lendo from comment #5)
> The toggle list button isn't available in the style formatting toolbar.

Button is available in the toolbar, but its hidden.

> Interesting, thanks. But there is no command suggested, only new list
> entries, etc. what doesn't help in toolbars/Notebookbars.

The addition of the 'none' list entry will give a similar entry as the default paragraph and default character style entries found style formatting toolbar.
Comment 9 Thomas Lendo 2018-01-14 19:01:54 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> (In reply to Thomas Lendo from comment #5)
> > Interesting, thanks. But there is no command suggested, only new list
> > entries, etc. what doesn't help in toolbars/Notebookbars.
> 
> The addition of the 'none' list entry will give a similar entry as the
> default paragraph and default character style entries found style formatting
> toolbar.
The problem is that there is no no-list style like the default character style which "deletes" other character styles (because the default list is a list and not no list ;). Such entry would be needed--then this could be added as own style button in a toolbar which I ask for in this bug.

Now the only solution is a list widget. But I don't like that as you also wouldn't agree that to set back a paragraph style is only possible with a paragraph style list widget and not with an own command.
Comment 10 Yousuf Philips (jay) (retired) 2018-01-15 15:30:02 UTC
(In reply to Thomas Lendo from comment #9)
> The problem is that there is no no-list style like the default character
> style which "deletes" other character styles (because the default list is a
> list and not no list ;).

Default character style isnt a style, it removes the character style associated with text, and in the same way 'No List' also wouldnt be an actual style but would remove the list style associated with text.

> Such entry would be needed--then this could be
> added as own style button in a toolbar which I ask for in this bug.

This bug report asks for a command to remove a list, and there is already one for direct formatting and one for styles will be available when bug 101965 if fixed.

> Now the only solution is a list widget. But I don't like that as you also
> wouldn't agree that to set back a paragraph style is only possible with a
> paragraph style list widget and not with an own command.

Sorry didnt follow.
Comment 11 Thomas Lendo 2018-01-16 20:57:38 UTC

*** This bug has been marked as a duplicate of bug 101965 ***
Comment 12 Thomas Lendo 2018-01-17 20:35:14 UTC
Cor noted in bug 101965 comment 4 that .uno:RemoveBullets already exists and it's assigned to Ctrl+Shift+F12.

I missed that completely.
Therefore this is truly a WFM and no dupe. Sorry for the fuss.