Bug 114905 - CRASH: LibreOffice crashes opening the new file dialog from the notebookbar
Summary: CRASH: LibreOffice crashes opening the new file dialog from the notebookbar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2018-01-08 11:13 UTC by Xisco Faulí
Modified: 2018-07-08 11:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: ["SfxDispatcher::GetFrame()"]


Attachments
gdb backtrace (22.16 KB, text/plain)
2018-01-09 15:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-01-08 11:13:40 UTC
Steps to reproduce:
1. Change to the notebookbar view. View - Toolbar layout - notebookbar
2. Go to File - Text Document ( LibreOffice Writer icon )
3. Click on the Open icon ( left top corner )
CRASH!

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 0ef0740298b45379bbf8d00d50beffee7a2f812a
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-01-08 11:33:58 UTC
Regression introduced by:

author	Yousuf Philips <philipz85@hotmail.com>	2017-09-23 20:52:26 +0400
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-10-01 21:03:04 +0200
commit	f4944b4e9b8ce8aeb521613cc67334f256b8cc31 (patch)
tree	8b8ed790e86d1131fa6a284eadc5538e03d19c23
parent	0e3c3350cd7ef4b8d1b52fb6e5d8d17644cc4e61 (diff)
tdf#107237 Reorganized File tab of Notebookbar

Bisected with: bibisect-linux64-6.0

Adding Cc: to Yousuf Philips

I guess the crash happens because when we create the new document from the icons, the focus remains in the icons, whereas it should be in the new document
Comment 2 Yousuf Philips (jay) (retired) 2018-01-08 16:15:39 UTC
Szymon, Maxim: thoughts why private:factory/swriter works fine from the menu bar, but causes this crash after executing it through a gtkbutton in the notebookbar.
Comment 3 Xisco Faulí 2018-01-09 15:54:38 UTC
Created attachment 138999 [details]
gdb backtrace
Comment 4 Xisco Faulí 2018-01-15 21:55:45 UTC
Caolán, one for you ?
Comment 5 Caolán McNamara 2018-01-19 15:09:59 UTC
I can't reproduce this, probably not my bug anyway
Comment 6 Chandanathil P. Geevan 2018-01-25 13:21:38 UTC
The RC2 crashed while I was trying to reset back to the old default after trying out varying options in the Notebookbar. I'm unable to replicate it. Not sure when exactly it happened. I'll try to experiment and inform/ update. Filing this to draw attention and to ensure that the final release do not have such a problem.
Comment 7 Chandanathil P. Geevan 2018-01-25 13:26:20 UTC
The crash happened so suddenly, I had not kept track of my steps. I'll try again and try to replicate. In the meantime, you should examine reasons as to why there was a crash.
Comment 8 Aron Budea 2018-07-07 23:53:08 UTC
Xisco, is this crash still reproducible for you in 6.1.0.1? I can see the layout has somewhat changed, and there's no crash for me anymore.
Comment 9 Xisco Faulí 2018-07-08 11:46:27 UTC
(In reply to Aron Budea from comment #8)
> Xisco, is this crash still reproducible for you in 6.1.0.1? I can see the
> layout has somewhat changed, and there's no crash for me anymore.

Yep, you're right, I can't reproduce it anymore with the new layouts

Version: 6.2.0.0.alpha0+
Build ID: 363146254bd44ab82d657f2ca0293d03bd111280
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

closing as RESOLVED WORKSFORME