Bug 114908 - VIEWING: Text-flow not correct from 5.2 for ODT with near-by tables (5, 6 and 8 pages instead of 4)
Summary: VIEWING: Text-flow not correct from 5.2 for ODT with near-by tables (5, 6 and...
Status: RESOLVED DUPLICATE of bug 118528
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-01-08 12:43 UTC by AndiLibre
Modified: 2018-07-19 11:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample writer file to show rendering display issue LO 5.2.x vs LO 5.3.x (888.48 KB, application/vnd.oasis.opendocument.text)
2018-01-08 12:43 UTC, AndiLibre
Details
how it looks before the commit - 6 pages (72.23 KB, application/pdf)
2018-01-08 14:31 UTC, Xisco Faulí
Details
how it looks after the commit - 7 pages (72.97 KB, application/pdf)
2018-01-08 14:31 UTC, Xisco Faulí
Details
how it looks wih LO 5.1.6 - 4 pages (78.53 KB, application/pdf)
2018-01-09 10:46 UTC, Timur
Details
Sample text compared (181.55 KB, image/jpeg)
2018-07-19 09:44 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AndiLibre 2018-01-08 12:43:43 UTC
Created attachment 138963 [details]
Sample writer file to show rendering display issue LO 5.2.x vs LO 5.3.x

Opening the attached document in 5.2.x branch shows the document fine with two blocks named "Iteration" mostly on the first page.

The same document opened in 5.3.x shows just the first table on the "1. Iteration" block. The document display can be fixed by choosing "View -> Web preview" and then changing back to "View -> Normal".
This is not reliably putting the document into the correct state or fixes the document display for later editing though.

It appears to be a rendering issue between the different LO versions. Wondering what is causing the issue within the document so we could work around it.
Comment 1 Xisco Faulí 2018-01-08 14:30:21 UTC
Regression introduced by:

author	Justin Luth <justin_luth@sil.org>	2015-11-27 19:03:40 +0300
committer	Justin Luth <justin_luth@sil.org>	2016-01-18 04:30:59 +0000
commit	0d127baed75929e744d5b6249f510012cfbc0e88 (patch)
tree	428628b43ebaa4fdb40e6077aac0964ae9e195b4
parent	57997db73725583a84dbac36bcc9c1b2829948f9 (diff)
tdf#91083 - .doc: emulate table keep-with-next paragraph
connect table with the following paragraph.  Move forward to a new page
together with the following paragraph if necessary.

Most of the added code allows the table to split if
all of the kept items do not fit on one page - allowing
the emulated table to match the layout of kept tables.

The only difference with .doc occurs when the table itself is larger
than one page.  In that case it ALWAYS starts a new page.  Although
it does not match .odt, it DOES match how MSWord handles that .doc.

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Justin Luth
Comment 2 Xisco Faulí 2018-01-08 14:31:41 UTC
Created attachment 138967 [details]
how it looks before the commit - 6 pages
Comment 3 Xisco Faulí 2018-01-08 14:31:59 UTC
Created attachment 138968 [details]
how it looks after the commit - 7 pages
Comment 4 Timur 2018-01-08 14:48:08 UTC
With LO 5.1.6 it's 4 pages file with 1. Iteration and 2. Iteration on the 1st page.
With LO 5.2.0 and 5.3.7 it's 5 pages file with 1. Iteration Tab1 Z1.1 on the 1st page and Tab2 Z1.1 and on on the 2nd.
With LO 5.4.3a and 6.0 beta 2 it's 6 pages file.
With master 6.1+ it's 8 pages file.
While it's true that View Web/Normal reflows something, not all is fixed.
Comment 5 Justin L 2018-01-08 18:35:58 UTC
(In reply to AndiLibre from comment #0)
> Wondering what is causing the issue within the document so we could work
> around it.

The primary style (Text Default Fett) has the rather unusual setting of "Text Flow" having "Keep with next Paragraph" enabled. Disabling that will provide the layout flow that you want - at least for the sample document provided. Keep with next is appropriate for titles/headings (so that they stick with the following content).
Comment 6 Timur 2018-01-09 10:46:32 UTC
Created attachment 138993 [details]
how it looks wih LO 5.1.6 - 4 pages

What Justin wrote explains "1. Iteration and 2. Iteration on the 1st page". 
I'm not sure whether it's a bug then. It used to preview better. 

Even with that we still have 6 pages.
There are 2 other issues why we don't have 4 pages like in 5.1.6.
Like why pages 4,5,6 are not on a single page. 
Looks like a different issue.
Comment 7 Justin L 2018-07-18 19:25:10 UTC
Fixed in 6.2 and requesting a backport to 6.1.
I changed the emulation so that it is not triggered by inherited (aka styles) properties.

*** This bug has been marked as a duplicate of bug 118528 ***
Comment 8 Timur 2018-07-19 09:44:12 UTC
Created attachment 143637 [details]
Sample text compared

I confirm 6 pages and "1. Iteration and 2. Iteration on the 1st page" issue resolved with libo-master~2018-07-19_05.23.09_LibreOfficeDev_6.2.0.0.alpha0_Win_x86.

What remains is "Allgemeine Geschäftsbedingungen" table issue that was 1 page until 5.4.x and now has empty pages before and after. 
Looks like some reflow issue from 5.4.2 or 5.4.3. Not sure why and if there's already bug for that.
Comment 9 Justin L 2018-07-19 10:41:23 UTC
(In reply to Timur from comment #8)
> What remains is "Allgemeine Geschäftsbedingungen" table issue that was 1
> page until 5.4.x and now has empty pages before and after. 
> Looks like some reflow issue from 5.4.2 or 5.4.3.
I wouldn't worry too much about that.  When everything in the document wants to be connected to the last paragraph, that is going to cause interesting problems. Maybe if some expert in layout wants a challenge, they can play with it.
Comment 10 Timur 2018-07-19 11:17:50 UTC
Found it, automatic hyphenation not working because I didn't have German dict. installed in LO master. When I installed it, all is fine, 4 pages. 
Sorry for a false alarm and thank you.