Bug Hunting Session
Bug 114927 - In the Austrian localization of Calc the German word "Januar" isn't recognized as a date.
Summary: In the Austrian localization of Calc the German word "Januar" isn't recognize...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2018-01-09 11:51 UTC by ingo
Modified: 2018-10-23 11:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ingo 2018-01-09 11:51:23 UTC
Description:
This bug concerns dates copied into calc with de-AT (de_AT.UTF-8) (Austrian) localization.
In Austria people speak German, but with some variations. One is the word for january, which translates to "Jänner" OR "Januar". I can copy a date like "12. Jänner 2018" into calc an it is recognized as a date. But if I copy an equally often used date like "12. Januar 2018", it is NOT recognized as a date, but as text. Both "Jänner" and "Januar" are used in Austria and should therefore be handled as dates.

This might be necessary for the German localization too, since some southern parts of Germany use the word "Jänner" too.

Steps to Reproduce:
1.Format a cell to date-format
2.Copy a text like "12. Januar 2018" into this cell


Actual Results:  
The cell will show the copied text as "text".

Expected Results:
The cell should turn the text into a date, like it does with a text like "12. Jänner 2018".


Reproducible: Always


User Profile Reset: No



Additional Info:
This problem might occur in the German localization too, just the other way around (recognizing "Januar" but not "Jänner"). 

Version: 5.4.2.2
Build-ID: 1:5.4.2-0ubuntu0.17.10.1
CPU-Threads: 8; Betriebssystem:Linux 4.13; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-AT (de_AT.UTF-8); Calc: CL


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.94.1008.40
Comment 1 Regina Henschel 2018-01-09 19:57:47 UTC
You can set the language in a number format. Set "German (Austria)" for detecting "Jänner" and "German (German)" for detecting "Januar". Detecting numbers and dates without language information makes no sense.
Comment 2 ingo 2018-01-09 20:42:14 UTC
(In reply to Regina Henschel from comment #1)
> You can set the language in a number format. Set "German (Austria)" for
> detecting "Jänner" and "German (German)" for detecting "Januar". Detecting
> numbers and dates without language information makes no sense.

Thank you, that is actually very useful as a workaround for the problem I have right now, even though it doesn't solve the problem of working with mixed sources. In some cases "Januar" and "Jänner" are mixed together, depending on what the people filling out the forms use. The problem is, that both terms, "Januar" and "Jänner" are equally valid in the German language (de and at). Right now I have to treat the cells as text and create the date with additional formulas.
Comment 3 Thomas Lendo 2018-01-10 22:34:10 UTC
Januar and Jänner should be both detected as number format in all German languages. In mixed environments this would avoid problems.

Duden [1] says that Jänner also in Germany and Switzerland can be used in some regions. And as stated by the bug opener, Januar is equally used as Jänner in Austria in written form. My Österreichisches Wörterbuch says that Januar is also possible in Austria.

Therefore the differentiation is useless.

[1] https://www.duden.de/rechtschreibung/Jaenner
Comment 4 Xisco Faulí 2018-10-04 16:57:31 UTC
Dear Nickson Thanda,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 5 Xisco Faulí 2018-10-04 16:58:02 UTC
@Eike, I thought you could be interested in this issue...
Comment 6 Eike Rathke 2018-10-04 19:20:01 UTC
We don't have alternative month names in locale data nor supported in number scanner; this may be a valid request, someone would have to implement the feature.

Other than that, it could be brutally hacked in for German locales.
Comment 7 Commit Notification 2018-10-05 14:37:47 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5043cf9b5a4bfa93e1a88f81b931a13b7931bfd5

Resolves: tdf#114927 recognize both Januar and Jänner in de-* German locales

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-10-05 23:41:31 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f1ae0debdcb0d3e80651873b09ad23dfaa90123

Unit test for de-* Januar/Jänner, tdf#114927

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Thomas Lendo 2018-10-23 11:14:37 UTC
Verified. Thank you very much, Eike!

Version: 6.2.0.0.alpha1+ (x64)
Build ID: ae9f37ba753519ae4a2ae6384d052d417359602f
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-23_02:03:22
Locale: de-AT (de_AT); Calc: CL