Bug 114960 - Higher resolution of background images in templates
Summary: Higher resolution of background images in templates
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2018-01-11 10:11 UTC by Thomas Lendo
Modified: 2020-05-07 13:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Blue wave from a default template (147.56 KB, image/png)
2018-01-11 10:11 UTC, Thomas Lendo
Details
using a vectorgraphic (11.58 KB, application/vnd.oasis.opendocument.presentation-template)
2018-01-12 12:47 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-01-11 10:11:16 UTC
Created attachment 139047 [details]
Blue wave from a default template

The background images of the templates in LibO 6.0 seems to are in low resolution and looks pixelated. Higher resolution images should be included. No blur and "stairs" should be visible in non-vertical or non-horizontal borders/lines.

Tested with version 6.0.0.1 (x64)
Build-ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL
Monitor: 1920 x 1200 px, 24"
with NVIDIA Quadro K2200
Comment 1 Regina Henschel 2018-01-11 19:55:50 UTC
Such simple kind of decoration as in "Blue Curve" shouldn't be a raster graphic at all but a vector graphic, esp. as it is not the background graphic of the slide, but an image inserted as background object.
Comment 2 Laurent BP 2018-01-12 11:10:40 UTC
Please describe precisely which templates need to be improved.
Comment 3 Regina Henschel 2018-01-12 12:47:19 UTC
Created attachment 139069 [details]
using a vectorgraphic

The screenshot from Thomas Lendo is from template "Blue Curve". The image on the title slide master has width 1057 pixel and height 185 pixel. But the problem is deeper than exchanging the image. I have tried a vector graphic (see attachment). In edit mode it is fine, but in presentation mode anti-aliasing is missing. The problem is more visible in 4:3 than in 16:9. So using vector graphic (as I first thought), will currently not solve the problem .
Comment 4 Thomas Lendo 2018-01-15 21:33:14 UTC
(In reply to Laurent BP from comment #2)
> Please describe precisely which templates need to be improved.
The Impress templates I mean are
- Beehive
- Blue Curve
- Blueprint Plans
- DNA
- Forestbird
- Nature Illustration
- Pencil
- Vintage
Comment 5 QA Administrators 2019-01-16 03:54:38 UTC Comment hidden (obsolete)
Comment 6 andreas_k 2020-05-01 08:41:24 UTC
All Templates get an update and the master page background are now LibreOffice shapes so there is no resolution issue any more.

Two templates didn't get an update (now) and use the old background cause I was to lazy.