Bug 114980 - "Preparing preview" for master slides "Recently used" or "Used in this presentation" takes a long time sometimes
Summary: "Preparing preview" for master slides "Recently used" or "Used in this presen...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL: https://www.dropbox.com/sh/fl240wr1fa...
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Sidebar-Master-Pages
  Show dependency treegraph
 
Reported: 2018-01-12 15:13 UTC by Harald Berger
Modified: 2018-06-02 11:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots showing the preview stages (47.35 KB, image/png)
2018-02-11 15:03 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Berger 2018-01-12 15:13:13 UTC
Description:
In LibreOffice version: 6.0.0.1 (x64)
Build-ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
there in IMPRESS - sidebar-masterslides are the thumbnails
no longer shown at a distance. Two screenshots of the sidebars V5 and V6.0.0.1 (x64) for comparison, can be found here be considered: https://www.dropbox.com/sh/fl240wr1fay6ty5/AADQoiFG8w2y1TBpdkHy0vD0a?dl=0

Actual Results:  
Open the sidebar-masterslides

Expected Results:
In the sidebar-masterslides are the thumbnails
no longer shown at a distance.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Buovjaga 2018-02-11 12:45:17 UTC
You mean the "Preparing preview" message? I do see it, but in "Used in this presentation". Seems like the same root cause, so setting to NEW.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: c6a23023150c164a19236139fa413d43006ce21c
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 11th 2018
Comment 2 Buovjaga 2018-02-11 13:02:18 UTC
Hmm, now I noticed that it did successfully prepare the preview after waiting longer.
Comment 3 Harald Berger 2018-02-11 14:34:05 UTC
Hi Buovjaga, i don't no what you mean. Please look again at the dropbox (URL), there  is a new picture with the overall view, named "IMPRESS LO-V6-0-0-3_Gesamtbild.png". There is no modification after waiting. I hope i can help you.
Comment 4 Buovjaga 2018-02-11 15:03:51 UTC
Created attachment 139787 [details]
Screenshots showing the preview stages

I had to wait a long time, maybe 20 minutes for the preview to appear
Comment 5 Harald Berger 2018-02-11 16:38:57 UTC
Your attachment http://bugs.documentfoundation.org/attachment.cgi?id=139787 shows the same Problem. There is no modification after waiting 90 minutes on my system.
Comment 6 Buovjaga 2018-06-02 11:42:49 UTC
I was going to bibisect this, but I cannot reproduce this with bibisect-win32-6.0. Still repro with master on Win.
Comment 7 Harald Berger 2018-06-02 11:52:34 UTC
Now it's the thame Bug in Windows10, 64-Bit
Version: 6.0.4.2 (x64)
Build-ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group