Bug 114987 - 100% CPU usage on launch(& running) [on Intel & Nvidia GPU]
Summary: 100% CPU usage on launch(& running) [on Intel & Nvidia GPU]
Status: RESOLVED DUPLICATE of bug 108246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://imgur.com/a/91qmh
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-13 14:24 UTC by florian
Modified: 2018-01-13 17:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Perf-Output (234.21 KB, text/plain)
2018-01-13 14:28 UTC, florian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description florian 2018-01-13 14:24:28 UTC
Description:
At Libreoffice launch, CPU goes to +100% and stays there.
It 'travels' from core to core, without dropping (see attached file).
Isolation mode is active (meltdown patch) on my kernel.

uname:
Linux arch-bug-box 4.14.12-1-ARCH #1 SMP PREEMPT Fri Jan 5 18:19:34 UTC 2018 x86_64 GNU/Linux

version:
LibreOffice 5.4.4.2 40m0(Build:2)

Steps to Reproduce:
1. Launch libreoffice and watch your cpu crumble

Actual Results:  
see above

Expected Results:
Not having my workstation produce a hurricane..


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.10.0 Chrome/61.0.3163.140 Safari/537.36
Comment 1 florian 2018-01-13 14:28:25 UTC
Created attachment 139079 [details]
Perf-Output

perf record output
Comment 2 florian 2018-01-13 14:40:09 UTC
https://bugs.archlinux.org/task/57036
Comment 3 Caolán McNamara 2018-01-13 14:53:01 UTC
given the archlinux comments, what's your version of glib2 ?
Comment 4 florian 2018-01-13 15:05:22 UTC
(In reply to Caolán McNamara from comment #3)
> given the archlinux comments, what's your version of glib2 ?

glib2 version: 2.54.3-1
Comment 5 Caolán McNamara 2018-01-13 17:11:34 UTC
Archlinux bug reports fixed with glib2: 2.54.3-2
Comment 6 Buovjaga 2018-01-13 17:34:13 UTC
from bug 108246: "The previous patch that fixed this issue in glib was reverted in 2.54.3"

*** This bug has been marked as a duplicate of bug 108246 ***