Download it now!
Bug 115017 - SVG images are clipped incorrectly
Summary: SVG images are clipped incorrectly
Status: RESOLVED DUPLICATE of bug 97539
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2018-01-15 09:50 UTC by mail
Modified: 2019-09-19 16:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG generated by matplotlib, renders incorrectly in LO (49.11 KB, image/svg+xml)
2018-01-15 09:52 UTC, mail
Details
Image exported as PNG by matplotlib (113.32 KB, image/png)
2018-01-15 09:56 UTC, mail
Details
Wrongly rendered SVG image, exported as PNG (41.04 KB, image/png)
2018-01-15 09:59 UTC, mail
Details
reduced file, which still shows the error (1.83 KB, image/svg+xml)
2018-01-16 00:58 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2018-01-15 09:50:41 UTC
Description:
SVG images exported by Python's matplotlib are not clipped correctly, the matplotlib developers have closed a corresponding bug report years ago, describing the root cause in detail (https://github.com/matplotlib/matplotlib/issues/4341).

The attached file renders correctly e.g. in Firefox.

Steps to Reproduce:
1. import the attached SVG-file into a drawing

Actual Results:  
The actual plot curve overlaps the axes.

Expected Results:
The actual plot curve should be within the plotting window.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 mail 2018-01-15 09:52:43 UTC
Created attachment 139102 [details]
SVG generated by matplotlib, renders incorrectly in LO
Comment 2 mail 2018-01-15 09:56:04 UTC
Created attachment 139103 [details]
Image exported as PNG by matplotlib

This is the correct rendering as rendered e.g. by Firefox
Comment 3 mail 2018-01-15 09:59:55 UTC
Created attachment 139104 [details]
Wrongly rendered SVG image, exported as PNG

This PNG is exported by LO, showing LO's faulty rendering of SVG images
Comment 4 Telesto 2018-01-15 21:39:10 UTC
Confirming with
Version: 6.1.0.0.alpha0+
Build ID: 80fb8d406ced47e6a2089f0c8ba5c103d2fec91f
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-15_05:18:42
Locale: nl-NL (nl_NL); Calc: CL

and with
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5
Comment 5 Regina Henschel 2018-01-16 00:58:49 UTC
Created attachment 139119 [details]
reduced file, which still shows the error

It has nothing to do with the position of the clipPath definition. I have moved it to the begin and removed all <g> elements, so that it is on same level as the referencing element and known before used.

I think it is similar to bug 97657: The clip-path attribute is not supported.

It makes no difference, whether you use a path or rect for the clipPath.
Comment 6 Regina Henschel 2018-11-05 23:28:25 UTC
The error still exists in Version: 6.2.0.0.alpha1+ (x64)
Build ID: e33424dd887cb1a11a3dba2513ef0f4bf93a6dbe
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-01_00:43:29
Locale: de-DE (en_US); Calc: CL
Comment 7 Xisco Faulí 2019-09-19 11:58:47 UTC
*** Bug 100135 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-09-19 16:15:33 UTC
Reverting 5903235d57acb13d9d5286d23b443a01aeab9a3c would fix this issue. thus, duplicate of bug 97539

*** This bug has been marked as a duplicate of bug 97539 ***