Bug 115042 - Enhancement: allow more fields in presentations
Summary: Enhancement: allow more fields in presentations
Status: RESOLVED DUPLICATE of bug 53548
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 13:31 UTC by sergio.callegari
Modified: 2018-01-16 14:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-01-16 13:31:45 UTC
Description:
LibO Writer has an "Insert -> Field" functionality that includes a "More fields" option which basically lets one include any kind of document property into a document, including custom properties.

LibO Impress also has an "Insert -> Field" functionality, however this is much more limited. There are only some basic fields listed corresponding to the most fundamental document properties and no "More fields" option. This basically prevents using the document custom properties as fields in presentations.

Conversely, this functionality would be quite useful. Think of slides where each slide needs to include a revision number. If there is a single master page the presentation depends on, the number can be put on the master page. However, if there are multiple master pages, updating the revision number means updating /all/ of them. Having the revision number in a single place in a custom variable would help a lot.

In principle being able to refer custom variables in a presentation would also help flows where documents are stored in vcs such as git. One could easily code an output filter replacing an output variable with a git id or tag, etc and have it referred inside the presentation.

Steps to Reproduce:
See description

Actual Results:  
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Falkon/2.1.99 Chrome/56.0.2924.122 Safari/537.36
Comment 1 Regina Henschel 2018-01-16 14:15:22 UTC
Yes such fields are still missing. Request is already in bug 53548.

*** This bug has been marked as a duplicate of bug 53548 ***