Download it now!
Bug 115044 - Calc asks to update links, but already updated them
Summary: Calc asks to update links, but already updated them
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.1 target:5.4.5
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 13:50 UTC by Vasily Melenchuk (CIB)
Modified: 2018-01-31 21:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
main.ods (8.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-01-16 13:51 UTC, Vasily Melenchuk (CIB)
Details
include.ods (8.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-01-16 13:51 UTC, Vasily Melenchuk (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasily Melenchuk (CIB) 2018-01-16 13:50:10 UTC
Description:
If calc was able to update linked data from another opened documents, it does so, but still asks user if he wants to update data.

Steps to Reproduce:
1. Open main.ods
2. Note value "1" in A1 cell and dialog asking to update external links.
3. Close main.ods
4. Open include.ods (note value "42" in A1 cell)
5. Open main.ods without closing include.ods
6. Note updated value "42" and dialog asking to update external links.

Actual Results:  
LO shows updated values in table and at the same asks to update.

Expected Results:
If all external data were updated no dialog should appear.
-or-
Data should not be updated if user did not allowed it yet.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Vasily Melenchuk (CIB) 2018-01-16 13:51:02 UTC
Created attachment 139128 [details]
main.ods
Comment 2 Vasily Melenchuk (CIB) 2018-01-16 13:51:21 UTC
Created attachment 139129 [details]
include.ods
Comment 3 Xavier Van Wijmeersch 2018-01-16 15:24:52 UTC
In tools/options/LibreOffice Calc/general there is a item "Update links on opening" with three choices Always; default is On request and Never.
(Steps 4=>6) When uncheck the "On request" and check "Never" the problem goes away when the opening document is updated on his own. But with "Never" checked i think this is not always a good solution, because when the main document is first opened and then the include document there is no update. So how to update these document when the request is not showing?
Comment 4 Eike Rathke 2018-01-22 15:25:19 UTC
Updating external reference values even if already loaded without asking is already wrong. Rather than silently doing that and suppressing the confirmation, the update should be delayed until after confirmation.
Comment 5 Commit Notification 2018-01-30 00:21:08 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b98991a66197a71953dbb900dc3aece6b4f9e3a

tdf#115044: do not load external documents if it is not allowed

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-01-30 09:45:58 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cef36cbbeafa9d7899bfb9c2404dec253cc86ee2&h=libreoffice-6-0

tdf#115044: do not load external documents if it is not allowed

It will be available in 6.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-01-30 09:46:08 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e7c8c3a1be5c266f8ba7ad42fd9ce80beae5264&h=libreoffice-5-4

tdf#115044: do not load external documents if it is not allowed

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.