Bug 115064 - Deprecation of old text layout engine in 5.3 breaks font based tags (data fields) used by applications like ActiveFax (ActFax)
Summary: Deprecation of old text layout engine in 5.3 breaks font based tags (data fie...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2018-01-17 09:37 UTC by Rolf Eder
Modified: 2018-07-31 11:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of ActFax properties dialogue (15.15 KB, image/png)
2018-01-22 10:13 UTC, Rolf Eder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eder 2018-01-17 09:37:18 UTC
Description:
Since rel. 5.4 old text layout engine is gone and workaround used in 5.3 (org.openoffice.office.common | VCL = old) to prevent use of HarfBuzz has no effect. Font based tagging by embedding "data fields" in documents to process jobs used by ActiveFax is now broken.
Thus tdf#89870 is not resolved for us. Only workaround seems to stick with rel. 5.3 or use other software with different font rendering.

Steps to Reproduce:
1. Insert tags like @F211 1234567890@ in document and format this sequence with font "ActiveFax".
2. Print document on printer "ActiveFax".

Actual Results:  
ActiveFax client dialogue pops up and asks for target (e.g. fax number, mail address, ...). Fax number 1234567890 in given example is not processed or read by the application.

Expected Results:
ActiveFax client reads and processes tags in document in background. No user interaction is required when tagging is in correct format and syntax. Only tags formatted with font ActiveFax are processed. On the resulting fax or mail attachment these tags are blanked and not visible for the receiver.  


Reproducible: Always


User Profile Reset: Yes



Additional Info:
ActFax manual is here:
http://www.actfax.com/download/actfax_manual_en.pdf

Data field section is on pages 96-107.

We process several thousand documents with ActiveFax tags each year and entering the data field information manually breaks workflows. Definitely a show stopper for us.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0.2 Safari/604.4.7
Comment 1 Aron Budea 2018-01-22 04:31:22 UTC
What kind of font is ActiveFax? This page says it's printer internal [1]. Does it mean only the name matters when it's processed by the machine?

Also, the manual says under "5.6.2. UNIX, Linux and other Operating Systems" that in non-Windows systems the font does not matter. What's the point of requiring it on Windows systems, I wonder.

[1] https://activefax.wordpress.com/2007/12/01/the-activefax-font-is-not-available-in-the-font-selection-window/
Comment 2 Rolf Eder 2018-01-22 10:13:30 UTC
Created attachment 139255 [details]
Screenshot of ActFax properties dialogue
Comment 3 Rolf Eder 2018-01-22 10:14:26 UTC
The ActiveFax font is a combination of Truetype font and printer internal font. Applications normally use the Truetype font which is then mapped by the printer driver to the printer internal ActiveFax font. I have attached a screenshot of where this mapping is done in the driver.
Comment 4 V Stuart Foote 2018-01-22 13:33:31 UTC
It was deprecated at 5.3, dropped at 5.4

Also, does ActiveFax install the ActFfont to system with the client service printer installation?

Have you opened a ticket with vendor ActFax?
Comment 5 Rolf Eder 2018-01-22 14:02:00 UTC
(In reply to V Stuart Foote from comment #4)

> Also, does ActiveFax install the ActFfont to system with the client service
> printer installation?

ActiveFax client installs and registers TrueType font in Windows font folder.

> Have you opened a ticket with vendor ActFax?

They checked this case and said it looks like LibO renders the tags formatted with the ActFax font as graphics before the ActFax printer actually kicks in. Therefore the data fields are not recognized by the driver and their contents cannot be processed.
Comment 6 QA Administrators 2018-07-31 09:38:08 UTC Comment hidden (obsolete)
Comment 7 Rolf Eder 2018-07-31 10:15:02 UTC
Bug may be closed as we cannot assume to get back the old text layout engine from release 5.2 or older.

Our workaround in case of ActFax: the target fax number or email address can be included in the filename and thus will be processed by ActFax printer in background (without user interaction).

If there are many data fields used this will break the max file name length sometime. In this case you may use an external reference file tagged by @F500 in the file name where all other data fields like fax number, subject etc. can be included.
Comment 8 Timur 2018-07-31 11:46:49 UTC
Since no alternative solution was proposed, I'll close per previous comment.