Bug 115092 - crash report screen keeps popping up
Summary: crash report screen keeps popping up
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-18 15:14 UTC by harriet anders
Modified: 2019-09-20 13:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["ig9icd64.dll"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description harriet anders 2018-01-18 15:14:17 UTC
Description:
each time I start the program a notification screen pops ordering me to send a crash report - does not matter if I do or do not send; every new session it comes again - I have uninstralled the program with Revo, en did a fresh installation, to no effect, after re-installation it was still there, so I suppose it hides somewhere in teh register, which is annoying in itself

Actual Results:  
reinstalled the program

Expected Results:
to fix the problem


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
Comment 1 Xisco Faulí 2018-01-18 16:05:36 UTC Comment hidden (obsolete)
Comment 2 harriet anders 2018-01-30 16:19:20 UTC
please excuse late reply - I had not een the request;

yet: I changed the user-profile (which seemded indeed dating back from before I reinstalled;

after that I used the safe mode (which is included in that pop-up screen), to also reset the userprofile (the last radio-button)

neither did help, although I must admit that I did not restart the machine in between;

I could try and remove the program again and erase the user profile, and reinstall - would that help?

on itself it's no big deal - just another click to get rid of the pop-up screen - which is annoying, but that's all - the programm functions fine
Comment 3 Buovjaga 2018-02-17 19:15:40 UTC
Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 4 harriet anders 2018-02-19 09:32:57 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2018-02-19 09:57:05 UTC
(In reply to harriet anders from comment #4)
> Versie: 5.4.4.2 (x64)
> Build ID: 2524958677847fb3bb44820e40380acbe820f960
> CPU-threads: 4; Besturingssysteem:Windows 6.19; UI-render: GL; 
> Locale: en-US (en_US); Calc: group

I see you have OpenGL enabled. Try disabling it in Tools - Options - LibreOffice - View - Use OpenGL for all rendering
Comment 6 Xisco Faulí 2018-02-19 10:29:13 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2018-02-19 10:34:19 UTC
(In reply to Xisco Faulí from comment #6)
> Could you please provide the OpenGL info as well? ->
> https://wiki.documentfoundation.org/OpenGL#Windows
> 
> Setting to NEEDINFO

Actually the text contents of C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 8 QA Administrators 2018-09-03 14:49:57 UTC Comment hidden (obsolete)
Comment 9 harriet anders 2018-09-04 07:55:55 UTC
(In reply to Buovjaga from comment #7)
> (In reply to Xisco Faulí from comment #6)
> > Could you please provide the OpenGL info as well? ->
> > https://wiki.documentfoundation.org/OpenGL#Windows
> > 
> > Setting to NEEDINFO
> 
> Actually the text contents of
> C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

this is the requested info:
DriverVersion: 20.19.15.4390
DriverDate: 2-18-2016
DeviceID: PCI\VEN_8086&DEV_1912&SUBSYS_108E1025&REV_06
AdapterVendorID: 0x8086
AdapterDeviceID: 0x1912
AdapterSubsysID: 0x108e1025
DeviceKey: System\CurrentControlSet\Control\Video\{12ECC049-5E0E-11E8-AABE-D03F6CDDFAD8}\0000
Comment 10 Buovjaga 2018-09-04 16:25:24 UTC
Did disabling OpenGL help with the crash report issue?
Comment 11 harriet anders 2018-09-05 07:20:29 UTC
(In reply to Buovjaga from comment #10)
> Did disabling OpenGL help with the crash report issue?

Thank you for your reply: no, it didn't - 

to be honest I did not know the question was still open until I had a reminder a few days ago - I went as far as reinstalling (uninstalling through Revo) the program, but the message keeps popping up - meanwhile I'm so used to the extra click to make the call for the crashreoprt to go away that it just seems part of the start-up process - every once and a while it still annoys me a little, but basically I'm a happy user of LibreOffice - this small hiccup is quite acceptable - thanks for your help
Comment 12 Dieter Praas 2018-11-11 17:14:17 UTC
I'm not a developer, but perhaps it could help to send the crash report and to post the link to that crash report here. Perhaps somebody can get useful informations from that.
Comment 13 harriet anders 2018-11-13 10:02:00 UTC
just sent it, this is the url
crashreport.libreoffice.org/stats/crash_details/40388cfd-1b5d-4a6c-a9db-7e2051a912f5
Comment 14 Xisco Faulí 2018-11-13 10:39:29 UTC
Thanks for the crash signature.
all ig9icd64.dll crashes are related to Win 10.
Do you have any pending update on Windows ? does the crash gets fixed if you update it ?
Comment 15 Aron Budea 2018-11-13 12:31:41 UTC
I'd expect a driver update to a recent version will get rid of this crash.
Comment 16 harriet anders 2018-11-14 09:19:22 UTC
thank you for your replies;

when I first reported this, I suppose the pop-up window was there already for quite some time - I cannot imagine there hasn't been any windows-updates since then (home-edition: not much to choose);

I'm not sure which driver needs updating, or how to do that;

as I've written before, I've come to consider the extra click to open the program (or a document for that matter) as a slightly annoying but not as a great obstacle in using LibreOffice;

thank you for the continued interest;
Comment 17 Buovjaga 2018-11-14 09:27:38 UTC
You could try Device Manager -> Display adapters -> Intel(R) HD Graphics 530 - > Update Driver

It seems you have Intel HD 530. According to https://www.intel.com/content/www/us/en/support/products/88345/graphics-drivers/graphics-for-6th-generation-intel-processors/intel-hd-graphics-530.html the latest version is 25.20.100.6373 from this month while yours is 2,5 years old as we see from comment 9
Comment 18 Aron Budea 2018-11-14 10:39:56 UTC
(In reply to Buovjaga from comment #17)
> It seems you have Intel HD 530. According to
> https://www.intel.com/content/www/us/en/support/products/88345/graphics-
> drivers/graphics-for-6th-generation-intel-processors/intel-hd-graphics-530.
> html the latest version is 25.20.100.6373 from this month while yours is 2,5
> years old as we see from comment 9
A small note here, the way Intel does things, the download version and the driver version tend to be completely different numbers, and one can't be figured out from the other, but the release date of the drivers should be a good point of reference.
Comment 19 harriet anders 2018-11-15 10:03:35 UTC
Updated the driver to version 22.20.16.4735 (and had, by chance, an apparently minor, update from W10 last night) but unfortunately it does not make any difference with the crash report: that's still there
Comment 20 Timur 2019-01-10 10:11:45 UTC
This is the only report for 20.109 Windows x-64 bugs from LO 5.2 where reporting is available to LO 6.2.0.1. 
We always have a question should this be confirmed, because we have not steps. 
My view is that we should, because of large number of crash reports.
Comment 21 Xisco Faulí 2019-01-15 17:59:09 UTC
(In reply to Timur from comment #20)
> This is the only report for 20.109 Windows x-64 bugs from LO 5.2 where
> reporting is available to LO 6.2.0.1. 
> We always have a question should this be confirmed, because we have not
> steps. 
> My view is that we should, because of large number of crash reports.

Unless we get steps on how to reproduce it, it doesn't make sense to move this particular report to NEW,ig9icd64.dll is a dynamic library, the same as mergedlo.dll. The reports from those crashes aren't informative at all...
Comment 22 Xisco Faulí 2019-03-21 12:59:21 UTC
Hello Harriet,
LibreOffice 6.2.2.2 is going to be released today, could you please try again
with this version to see if the problem has been resolved meanwhile? Thanks in
advance
Comment 23 harriet anders 2019-03-23 10:24:26 UTC
thank you for your continued interest in "my problem", I do appreciate your efforts!

I did as requested, downloaded and ran version 6.2.2.2. (and installing took unexpectedly long) - I had several messages about conflict with running processes, so I restarted the computer after the -succesfull-  install - unfortunately the pop-up screen is still there, I'm sorry to say; this is the fresh crashreport: crashreport.libreoffice.org/stats/crash_details/cf29f466-24f4-43fa-a11e-ba0d578ded23

cheers, h.
Comment 24 Aron Budea 2019-03-25 05:16:02 UTC
Could you please paste the current content of opengl_device.log? (as in comment 9)
Comment 25 harriet anders 2019-03-25 14:49:02 UTC
DriverVersion: 22.20.16.4735
DriverDate: 7-7-2017
DeviceID: PCI\VEN_8086&DEV_1912&SUBSYS_108E1025&REV_06
AdapterVendorID: 0x8086
AdapterDeviceID: 0x1912
AdapterSubsysID: 0x108e1025
DeviceKey: System\CurrentControlSet\Control\Video\{3600483E-27B6-11E9-8534-EE43CAC9A093}\0000
DeviceString: Intel(R) HD Graphics 530
Comment 26 Buovjaga 2019-03-25 14:55:59 UTC
(In reply to harriet anders from comment #25)
> DriverVersion: 22.20.16.4735
> DriverDate: 7-7-2017
> DeviceID: PCI\VEN_8086&DEV_1912&SUBSYS_108E1025&REV_06
> AdapterVendorID: 0x8086
> AdapterDeviceID: 0x1912
> AdapterSubsysID: 0x108e1025
> DeviceKey:
> System\CurrentControlSet\Control\Video\{3600483E-27B6-11E9-8534-
> EE43CAC9A093}\0000
> DeviceString: Intel(R) HD Graphics 530

I wonder why the driver is not being updated to something more recent?
Comment 27 Christian Lohmaier 2019-03-27 11:45:31 UTC
adding comment from https://lists.freedesktop.org/archives/libreoffice-bugs/2019-March/176629.html (outage): 

"windows says "the best drivers for your device are already installed", when I
tried for a fresh update - I will not tamper with that
thnks"
Comment 28 Xisco Faulí 2019-05-02 10:12:34 UTC
@Julien, do you think we should blacklist the driver considering Windows claims it's updated ?
Comment 29 Julien Nabet 2019-05-02 10:19:26 UTC
(In reply to Xisco Faulí from comment #28)
> @Julien, do you think we should blacklist the driver considering Windows
> claims it's updated ?

Indeed, I can't see other workaround than this. Now I'm not an expert.

I won't be able to submit a patch before tonight, so if you're interested, here's an example of blacklist I had done:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=7aeff452bfd308d122c319ed5135bd98e90590f8
but you may find other ones and may need to adapt a bit.
Comment 30 Xisco Faulí 2019-05-02 10:33:21 UTC
(In reply to Julien Nabet from comment #29)
> (In reply to Xisco Faulí from comment #28)
> > @Julien, do you think we should blacklist the driver considering Windows
> > claims it's updated ?
> 
> Indeed, I can't see other workaround than this. Now I'm not an expert.
> 
> I won't be able to submit a patch before tonight, so if you're interested,
> here's an example of blacklist I had done:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=7aeff452bfd308d122c319ed5135bd98e90590f8
> but you may find other ones and may need to adapt a bit.

Patch in gerrit: https://gerrit.libreoffice.org/#/c/71666/
Comment 31 Commit Notification 2019-05-02 14:53:37 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ed423da9d968d6f534a6d4d27b45aa96cd5b47d4%5E%21

tdf#115092: blacklist Intel(R) HD Graphics 530

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Xisco Faulí 2019-05-02 14:55:12 UTC
Hello Harriet Anders,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ( date from tomorrow or later ) ?
You can install it alongside the standard version.
Comment 33 harriet anders 2019-05-03 11:45:44 UTC
thank you for your continuing attention;

from the list you provided, I'm not sure which one to chose, and equally not sure if a new installation does not affect my present - can you provide a portable version (i.e. an installation that does not nest itself in the register (please be aware that I have only limited technical knowledge);

I noticed that the status of my original question is set to "resolved"- that is not how I would phrase it: every time I start the progam I have to use an extra click to open it, because of this crash report

for the best part of the coming weeks I will be largely out of reach of Internet, if there are newer requests expect a delay in my responding

thank you, best h
Comment 34 Xisco Faulí 2019-05-03 11:49:54 UTC
(In reply to harriet anders from comment #33)
> thank you for your continuing attention;
> 
> from the list you provided, I'm not sure which one to chose, and equally not
> sure if a new installation does not affect my present - can you provide a
> portable version (i.e. an installation that does not nest itself in the
> register (please be aware that I have only limited technical knowledge);
> 
> I noticed that the status of my original question is set to "resolved"- that
> is not how I would phrase it: every time I start the progam I have to use an
> extra click to open it, because of this crash report
> 
> for the best part of the coming weeks I will be largely out of reach of
> Internet, if there are newer requests expect a delay in my responding
> 
> thank you, best h

Try this -> https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 35 V Stuart Foote 2019-05-03 14:29:34 UTC
(In reply to harriet anders from comment #33)

You'll need the instructions for a parallel installation as well, pretty simple once you've done it a couple of times.

https://wiki.documentfoundation.org/Installing_in_parallel
Comment 36 harriet anders 2019-05-04 09:30:42 UTC
installed the suggested version (Win64) in a separate folder, but could not find a way to make it run (and the explanation in the wiki howto is absolutely beyond me where it is on the Windows runtime feature, which is probably missing) - so I deleted this version again through Revo, which took worryingly long, but was hopefully complete;

again, I appreciate all your efforts, but you have to realise I'm merely a humble end-user, most certainly not computerwise at all (I find LibreOffice itself to be complex to work with in the first place);

I'll have a look here later on today (MET), but after that I'm offline for a few weeks - cheers
Comment 37 Buovjaga 2019-05-04 10:06:54 UTC
(In reply to harriet anders from comment #36)
> installed the suggested version (Win64) in a separate folder, but could not
> find a way to make it run (and the explanation in the wiki howto is
> absolutely beyond me where it is on the Windows runtime feature, which is
> probably missing) - so I deleted this version again through Revo, which took
> worryingly long, but was hopefully complete;

Eh, the wiki instructions are not needed, when using a daily master build. It should have been enough to simply install it. Then it is found under the name LibreOfficeDev.