Download it now!
Bug 115114 - Calc: Dragging a selected cell, or range of cells, is too difficult.
Summary: Calc: Dragging a selected cell, or range of cells, is too difficult.
Status: RESOLVED DUPLICATE of bug 38994
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-19 17:27 UTC by Michael Mast
Modified: 2018-01-22 19:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mast 2018-01-19 17:27:01 UTC
Description:
When using Calc and selecting a cell, or range of cells, the black outline indicating the cell (or range) is selected is too thin to click on and drag.  It takes several attempts to click and drag the mouse in order to drag the cell (or range of cells).  

Steps to Reproduce:
1. Open a spreadsheet (any spreadsheet or a new one).
2. Find a cell with a value in it (or enter a number in a cell).
3. Select the cell by clicking on it.
4. Attempt to drag the contents of the cell into another cell.

Actual Results:  
Most of the time, nothing happens.  Sometimes the contents of the cell is dragged into another cell (this is the expected result).

Expected Results:
I expect to be able to select and drag a cell nearly 100% of the time.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
I believe the tip of the arrow mouse cursor must be directly over the black outline indicating a cell is selected in order for click-and-drag to work.  I would "loosen" up the code a bit such that if the tip of the mouse is "near" the black outline the cell is draggable.


Version: 5.4.4.2
Build ID: 1:5.4.4~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: grou


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Thomas Lendo 2018-01-22 19:22:18 UTC
Thanks for your report, Michael.
Your bug seems to be a duplicate of bug 38994 from 2011. This is a very old issue back to the early days of OpenOffice.org.

Jeffrey in bug 38994 comment 1 cites an old workaround:
1) Click on the cell to give them a black border.
2) Drag the blue background to another cell.
3) Hold the click and drag back to the single cell.

*** This bug has been marked as a duplicate of bug 38994 ***