Bug 115152 - Writer freezes if OLE-Object form MS-Powerpoint was pasted from clipboard and Powerpoint is closed
Summary: Writer freezes if OLE-Object form MS-Powerpoint was pasted from clipboard and...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-22 14:44 UTC by Markus Grob
Modified: 2018-08-09 20:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test Powerpoint (32.46 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-01-22 14:44 UTC, Markus Grob
Details
Test Writer Document (8.58 KB, application/vnd.oasis.opendocument.text)
2018-01-22 14:44 UTC, Markus Grob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Grob 2018-01-22 14:44:19 UTC
Created attachment 139260 [details]
Test Powerpoint

I'm working on a document, in which a paste text from MS-Powerpoint from MS-Office 365. When I do a simple paste of the text, I get a OLE-object, which I can't use. So I go back a step and paste it with Shift-Ctrl-v (special-paste) into the document and choose "unformated text".
When I now close the powerpoint, LO freezes and I loose all since the last save.

I now have found out, that powerpoint was locked, when I closed it, before I closed LO. It seems, that LO generates a deadlock with the clipboard. When I manually kill the powerpoint process, LO works again. When I also close LO first, the deadlock did not happen.

I add 2 documents to test the situation (Win 7 64 Bit). For tests, do the following steps:
1. copy the word "test" from test.pptx to LO (Ctrl-c, Ctrl-v)
2. the OLE-Object should be pasted -> Ctrl-z to go back
3. paste again with Shift-Ctrl-v -> unformatted text -> test is pasted
4. close test.pptx -> powerpoint.exe process should remain and LO is locked
5. kill the process -> LO should work again

Sincerely, Markus
Comment 1 Markus Grob 2018-01-22 14:44:56 UTC
Created attachment 139261 [details]
Test Writer Document
Comment 2 Buovjaga 2018-02-12 17:46:55 UTC
I don't have PowerPoint on my own machine, so before I test myself, can you try with LibreOffice version 6.0.1?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 Markus Grob 2018-02-12 20:22:16 UTC
I have tested it again with 6.0.1. Same behaviour. I can clearivy, that it also happens, when I just copy an object or a page in PP. 
It seems, that LO locks the clipboard, so PP could not be closed normally. I have to kill the PP process, so that LO unfreezes again.
If I close LO and do the same, the PP process ends without a problem.

Sincerely, Markus
Comment 4 Buovjaga 2018-02-15 15:02:44 UTC
I tested and no problem with MSO 2013, but it is not the same as 365...
Comment 5 Markus Grob 2018-02-27 15:57:10 UTC
Could be, that the problem persists not in every environment, but as soffice.bin is monitoring the clipboard and the microsoft office process could not end, it seems, that this behaviour produces the deadlock which could only be reseted by killing the process manually but without libreoffice open, it doesn't happen.

Sincerely, Markus
Comment 6 Markus Grob 2018-08-09 20:44:49 UTC
I think I have found the bug. A password manager (password safe 7) was watching the clipboard and after disabling this function, the problem stopped.