Bug 115161 - FILESAVE DOCX Overlapping Shape and Field disappear
Summary: FILESAVE DOCX Overlapping Shape and Field disappear
Status: RESOLVED DUPLICATE of bug 134618
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Shapes DOCX-Fields
  Show dependency treegraph
 
Reported: 2018-01-22 22:57 UTC by Gabor Kelemen
Modified: 2020-08-31 13:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file saved by LO (8.07 KB, application/vnd.oasis.opendocument.text)
2018-01-22 22:57 UTC, Gabor Kelemen
Details
The example file saved as docx (14.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-01-22 22:58 UTC, Gabor Kelemen
Details
The example file in LO (2.58 KB, image/png)
2018-01-22 22:58 UTC, Gabor Kelemen
Details
The example file in Word (1.96 KB, image/png)
2018-01-22 22:59 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-01-22 22:57:59 UTC
Created attachment 139278 [details]
Example file saved by LO

Both the shape on top of the field and the field together disappear in Microsoft Word

Steps to reproduce:
1. Create a new document with LibreOffice.
2. Insert a predefined field (for instance page number).
3. Insert a shape on the top of the field.
4. Remove the area of the shape or send the shape into the background.
5. Save the file as .docx.
6. Compare the document in Word and Writer.

Actual results:
Both shape and field do not appear in Microsoft Word.

Expected results:
Both shape and field appear even in Microsoft Word.
Comment 1 Gabor Kelemen 2018-01-22 22:58:38 UTC
Created attachment 139279 [details]
The example file saved as docx
Comment 2 Gabor Kelemen 2018-01-22 22:58:58 UTC
Created attachment 139280 [details]
The example file in LO
Comment 3 Gabor Kelemen 2018-01-22 22:59:21 UTC
Created attachment 139281 [details]
The example file in Word
Comment 4 Aron Budea 2018-02-14 01:55:46 UTC
Reproduced using LO 6.0.1.1 & 4.4.0.3 / Windows 7.
Comment 5 NISZ LibreOffice Team 2020-08-31 13:04:54 UTC
This is solved with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7b156d37cfc92292323694ec064fe51ae57b3257

author	Michael Stahl <Michael.Stahl@cib.de>	2020-07-10 19:29:27 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-07-13 11:24:29 +0200

tdf#134618 sw: DOCX export: fix order of as-char and at-char fly...

*** This bug has been marked as a duplicate of bug 134618 ***