Download it now!
Bug 115246 - Unable to open xls (SpreadsheetML, XML Spreadsheet 2003, or XMLSS) on LibreOffice v5.4.4.2
Summary: Unable to open xls (SpreadsheetML, XML Spreadsheet 2003, or XMLSS) on LibreOf...
Status: RESOLVED DUPLICATE of bug 68742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-26 16:49 UTC by alara
Modified: 2018-01-27 18:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the truble file (4.37 KB, application/vnd.ms-excel)
2018-01-26 17:06 UTC, alara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alara 2018-01-26 16:49:30 UTC
Description:
I have does the installation of LibreOffice on my organization and they can open all documents except one, a .xls file (SpreadsheetML, XML Spreadsheet 2003, or XMLSS) who it´s generated from a third party CRM and i can´t change de code. 

I had googling that for more than two days and i can´t find a solution for that, that it´s a very important file for the organization. 	
the file code it´s ok for Microsoft Office.

Thanks in advance.

Steps to Reproduce:
1.Open the file
2.Select codification ISO-8859-1
3.Accept

Actual Results:  
The file open like text code, not like regular spreadsheet

Expected Results:
Open the file like a spreadsheet


Reproducible: Didn't try


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 5.4.4.2 (x64)
Build ID: 2524958677847fb3bb44820e40380acbe820f960
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 alara 2018-01-26 17:06:52 UTC
Created attachment 139382 [details]
This is the truble file

I add the file as attachment.
Comment 2 Mike Kaganski 2018-01-26 17:16:23 UTC

*** This bug has been marked as a duplicate of bug 68742 ***
Comment 3 Regina Henschel 2018-01-27 13:48:39 UTC
The empty lines are not the only problem in that file. If you remove the empty lines and the spaces before the processing instructions, then the file opens in Calc, but it is empty.

The additional problem is, that it uses
"urn:schemas-microsoft-com:office:Spreadsheet"
with a capital S
If you change the two occurrences to
"urn:schemas-microsoft-com:office:spreadsheet"
the file opens in Calc with content.
Comment 4 Mike Kaganski 2018-01-27 18:26:10 UTC
(In reply to Regina Henschel from comment #3)
> The empty lines are not the only problem in that file. ...
> The additional problem is, that it uses
> "urn:schemas-microsoft-com:office:Spreadsheet"
> with a capital S

Thank you Regina! You are absolutely right. And that is another reason why I generally dislike the idea to relax our parser to accept wrong syntax: if a generator does it wrong, there will be no end to different ways in which the output will be wrong.