Download it now!
Bug 115314 - base connection to Oracle db is slow
Summary: base connection to Oracle db is slow
Status: RESOLVED DUPLICATE of bug 63713
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-30 18:54 UTC by jkmin1
Modified: 2018-02-03 01:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jkmin1 2018-01-30 18:54:32 UTC
Description:
I use LibreOffice 5.1.6.2 in Ubuntu 16.04. I installed and tried jre1.8.0_74 jre1.8.0_152 jre1.7.0_80 openjdk 1.8.0_151. Also, I increased the memory for 300MB for libreoffice, and 50MB for per object.

When I sign in to a remote oracle 11g XE database on the local network with hr user(has sysdba role), it takes like 30 seconds or so to complete the login. After I get 50 or 200 initial rows from a table with select statemetn, if I go to the end of the table by clicking the end arrow with about 80K rows or so, it takes 4-5 minutes to retrieve the rows.

Steps to Reproduce:
1.connect to oracle 11G XE db on local network
2.sign in remotely with base to the oracle db
3.select rows from a table and then use the end arrow button to get last rows.

Actual Results:  
Logging in takes about 30 seconds
Retrieving or going to the last rows from a big table like 80K or so takes 4-5 minutes.

Expected Results:
Should be lot quicker than this


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 jkmin1 2018-01-30 18:59:19 UTC
I posted the question on the LibreOffice forum https://ask.libreoffice.org/en/question/144199/base-to-oracle-database-connection-slow/
Comment 2 Alex Thurgood 2018-01-31 08:30:53 UTC

*** This bug has been marked as a duplicate of bug 63713 ***
Comment 3 Alex Thurgood 2018-01-31 08:33:46 UTC
The problem apparently comes from actively refreshing the cache of object metadata each time a connection is made. This is very time consuming. There is currently no solution to this problem.
Comment 4 jkmin1 2018-01-31 17:39:47 UTC
(In reply to Alex Thurgood from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 63713 ***

After reading the contents of the bug, I see my bug filing is a duplicate.  I could not find that filing when I searched the bug titles using my title keywords. Thank you.
Comment 5 jkmin1 2018-01-31 17:40:17 UTC
(In reply to jkmin1 from comment #4)
> (In reply to Alex Thurgood from comment #2)
> > 
> > *** This bug has been marked as a duplicate of bug 63713 ***
> 
> After reading the contents of the bug, I see my bug filing is a duplicate. 
> I could not find that filing when I searched the bug titles using my title
> keywords. Thank you.
Comment 6 jkmin1 2018-02-03 01:16:43 UTC
I noticed that LibreOffice 6 is out. Is this fixed in LibreOffice6?
Thank you