Bug 115371 - export to HTML+CSS inside EPUB export is far behind export to HTML
Summary: export to HTML+CSS inside EPUB export is far behind export to HTML
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EPUB-Export
  Show dependency treegraph
 
Reported: 2018-02-01 12:44 UTC by Daniel Glazman
Modified: 2018-02-13 08:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Glazman 2018-02-01 12:44:14 UTC
Hello. As the implementor of a native EPUB2/EPUB3.0.1/EPUB3.1 Wysiwyg editor, I have briefly v6.0.0.3 and its export to EPUB. If the EPUB packaging export itself is quite good and shows very good stuff (for instance the possibility to split the document at page breaks or section headers), the inner export to XHTML+CSS is surprisingly far behind the regular "Export to XHTML" in LibreOffice. You'll find a report of my light tests at [1]. I hope that helps. Ping me any time if you need more info or if I can help.

[1] https://is.gd/LYpWdf
Comment 1 Miklos Vajna 2018-02-01 13:37:39 UTC
Care to test master instead?

Daily builds are here:

http://dev-builds.libreoffice.org/daily/

I've implemented a couple of improvements since the libreoffice-6-0 branch-off:

- https://vmiklos.hu/blog/epub3-improvements.html
- https://vmiklos.hu/blog/epub3-improvements-2.html

(The git history of LibreOffice core.git and libepubgen.git has more details, a number of bugfixes as well.)

Also, while your feedback is nice, it's not really actionable. The ideal bugreport has one ODT file as a reproducer and points out one specific expected behavior in the EPUB result, describing what is the actual result. Thanks!
Comment 2 Daniel Glazman 2018-02-01 14:10:36 UTC
(In reply to Miklos Vajna from comment #1)

> Care to test master instead?

Sure, will do.

> Also, while your feedback is nice, it's not really actionable. The ideal
> bugreport has one ODT file as a reproducer and points out one specific
> expected behavior in the EPUB result, describing what is the actual result.
> Thanks!

Yeah, but I wanted to reach out with the whole thing first. Will file individual bugs. Thanks.
Comment 3 Alex Thurgood 2018-02-06 08:15:36 UTC
@Daniel : is this specific to MacOS, or can I set all of these Epub export issues to ALL OSes ?
Comment 4 Daniel Glazman 2018-02-06 11:43:42 UTC
(In reply to Alex Thurgood from comment #3)
> @Daniel : is this specific to MacOS, or can I set all of these Epub export
> issues to ALL OSes ?

Probably not specific to OS X but I have no other platform here to test...
Comment 5 Alex Thurgood 2018-02-13 08:58:48 UTC
So, I'm unsure what to do with this report as there are no sample documents by which to compare (ODT, XHTML, HTML+CSS).

I see that you have opened a set of 4 bug reports with test ODT files included, so I'm inclined to close this particular report as INSUFFICIENTDATA. If you see a valid reason why we should keep this one open, please set back to UNCONFIRMED but you would need to provide a more specific test case (and different to the ones you have provided elsewhere).