Download it now!
Bug 115385 - Stuck in document recovery crash loop when starting LibreOffice
Summary: Stuck in document recovery crash loop when starting LibreOffice
Status: RESOLVED DUPLICATE of bug 112990
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-01 17:17 UTC by rebastion
Modified: 2019-10-12 21:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Recovery dialogue window (42.74 KB, image/png)
2018-02-01 17:18 UTC, rebastion
Details
blank recovery window (30.81 KB, image/png)
2018-02-01 17:18 UTC, rebastion
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rebastion 2018-02-01 17:17:28 UTC
Description:
I removed my previous LO installation incl. wiping user settings etc, to have a fresh installation. Now, whenever I try to start LO6, I get stuck in the eternal loop of document recovery hell. Discarding just creates new dialogues and it goes on and on and on.....

Steps to Reproduce:
1. Open LO
2. Click Discard when document recovery mode opens
3.

Actual Results:  
nothing, another dialogue opens with same or different documents, even blank documents, and the cycle repeats

Expected Results:
LO opens


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 rebastion 2018-02-01 17:18:06 UTC
Created attachment 139509 [details]
Recovery dialogue window
Comment 2 rebastion 2018-02-01 17:18:29 UTC
Created attachment 139510 [details]
blank recovery window
Comment 3 Julien Nabet 2018-02-01 17:33:02 UTC
Just to be sure, you can't even open LO? I mean just open it without trying to open a file

When you indicate you wiped your user settings, do you confirm you wiped your LO directory profile? (see https://wiki.documentfoundation.org/UserProfile#macOS)
Comment 4 Aron Budea 2018-02-01 17:38:25 UTC
I'm fairly sure it's a duplicate of bug 112990, and occurs with OpenGL rendering enabled. Please refer to the other bug report.

*** This bug has been marked as a duplicate of bug 112990 ***
Comment 5 rebastion 2018-02-02 07:42:45 UTC
Yes user profile cleared. I can start it, but it just gets stuck in recovery loop, no matter if I open LO or open it by opening a file....

However, I have looked at the duplicate bug, and I too can confirm that the problem disappears when I disable OpenGL
Comment 6 stavrosss 2019-09-02 09:05:16 UTC
https://ask.libreoffice.org/en/question/65224/prevent-libreoffice-process-from-getting-stuck/



"Hello, we recently switched about 30 PCs from old OpenOffice to the newest LibreOffice 5.1 and some users started complaining that their documents wont open. I traced the issue to the LO processes getting stuck when a user opens a multiple documents too fast or tries to open the same document second time when its taking long time to load. After the first process is stuck, each time a user open a document it just creates another stuck process and you have to kill them all to make LO work again. When you look in task manager there is a lot of soffice.bin, soffice.exe, writer, calc etc processes."

"I'm experiencing this with Libre 5.3 on Win 10 64-bit. Stops file opening after multiple Libre Office (32-bit) and Libre Office Calc (32-bit) background tasks. This was a fresh install of Libre Office on a new Win 10 machine.,"
Comment 7 Julien Nabet 2019-09-02 09:34:11 UTC
(In reply to stavrosss from comment #6)
> "Hello, we recently switched about 30 PCs from old OpenOffice to the newest
> LibreOffice 5.1 and some users started complaining that their documents wont
> open.
> ...
Last stable LO version is 6.2.6, there's even 6.3.0
5.X versions are EOL as 6.0.X and 6.1.X

If you still reproduce this with a real recent version, 
first check this:
https://wiki.documentfoundation.org/QA/FirstSteps

then please submit a new bugtracker if necessary.

About OpenGL related bugs, you must check you got last graphic drivers.

*** This bug has been marked as a duplicate of bug 112990 ***
Comment 8 L Jones 2019-10-12 19:17:25 UTC
Yes! Tip above fixed my problem.
Problem: fresh install (on mac 10.14.6) of Libreoffice 6.2.7, 6.2.8 beta, and 6.3.1 would crash ~ 40 seconds after launch, then restart, crash after 40 seconds again.

Solution: Immediately after Libreoffice opens, open Preferences > LibreOffice > Online Update, and uncheck "Check for updates automatically", "Apply", "OK", close LibreOffice, and reopen.

I am adding this comment to help others find this thread. 

I had already tried deleting user profile directory:
<userName>/Library/Application Support/OpenOffice
turned off OpenGL,
reverted Xcode from 11.1 to 10.3, and
rebooted several times. 

As noted abovce, I confirmed this bug affects 6.2.7, 6.2.8 beta and 6.3.1.
Comment 9 Julien Nabet 2019-10-12 21:33:33 UTC
Version must correspond to the earliest