Bug 115417 - Firefox themes not available
Summary: Firefox themes not available
Status: RESOLVED DUPLICATE of bug 114731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Julien Nabet
Depends on:
Reported: 2018-02-02 22:14 UTC by Kenneth Plasa
Modified: 2018-02-03 18:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Plasa 2018-02-02 22:14:44 UTC
LibreOffice doesn't show any selectable Firefox themes, and when I insert the URL of a particular Firefox theme and try to load it, LibreOffice responds that it can't be opened, and I shall try later again.

Steps to Reproduce:
1. Select menu "Extras"
2. Select submenu "Options"
3. Select "LibreOffice" in the left dialog window
4. Select "Personalization" in the left dialog window
5. Choose 3rd option in the right dialog window "Own Theme" or "Personal Theme" (German: "Eigenes Theme ...")
6. Click button "Select Theme" (German: "Thema auswählen ...") in right dialog window
8. Insert URL from Firefox theme (e. g., https://addons.mozilla.org/de/firefox/addon/red-ladybug/) into URL input area below text "Suchbegriff oder URL des Firefox-Themes" (German version)

Actual Results:  
7. No selectable themes available.
9. LibreOffice pops up new error window that the URL can't be openend, and I should try later.

Expected Results:
7. Selectable Firefox themes should be available.
9. URL with particular Firefox theme should be opened by LibreOffice.

Reproducible: Always

User Profile Reset: Yes

Additional Info:

User-Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
Comment 1 Julien Nabet 2018-02-03 10:18:35 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Kendy: debugging this, the pb appeared in parsePersonaInfo
    567     *pHeaderURL = searchValue( rBuffer, persona, ""headerURL":"" );
    568     if ( pHeaderURL->isEmpty() )
    569         return false;
It's from https://cgit.freedesktop.org/libreoffice/core/commit/?id=ca3fa2a210cc6978dc75566ff453c9138ab9c094

The buffer contains several ""headerURL":"", not ""headerURL":""
Is there some kind of mapping method to use?
Comment 2 Julien Nabet 2018-02-03 14:26:14 UTC
I submitted this patch for review:
Comment 3 Julien Nabet 2018-02-03 18:36:03 UTC
It seems this one is a dup, I'll update the patch.

*** This bug has been marked as a duplicate of bug 114731 ***