Bug Hunting Session
Bug 115428 - Crash in: MultiSalLayout::AdjustLayout(ImplLayoutArgs &)
Summary: Crash in: MultiSalLayout::AdjustLayout(ImplLayoutArgs &)
Status: RESOLVED DUPLICATE of bug 114736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-03 17:06 UTC by Massimo
Modified: 2018-02-06 08:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["MultiSalLayout::AdjustLayout(ImplLayoutArgs &)"]


Attachments
File crashing LO (20.76 KB, application/vnd.oasis.opendocument.graphics)
2018-02-04 10:36 UTC, Massimo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo 2018-02-03 17:06:46 UTC
This bug was filed from the crash reporting server and is br-e4ee9ea8-1cc9-4ba5-9244-bec154c6f7c8.
=========================================
Comment 1 Massimo 2018-02-04 10:36:32 UTC
Created attachment 139567 [details]
File crashing LO

If I try to open the attached file with LO6 in normal mode, I get systematic crash. I have to restart in Safe Mode to avoid crash. No problem with LO 5.4.4
Comment 2 Julien Nabet 2018-02-04 11:52:41 UTC
On pc Debian x86-64 with master sources updated yesterday + gtk3 or gen rendering, I don't reproduce this.

I just noticed this log:
warn:vcl:11007:11007:svtools/source/graphic/grfmgr.cxx:1052: Deprecated URL 'vnd.sun.star.GraphicObject:1000000000000020000000204B249CA79A42C6D7' was used to create a GraphicObject

For the test, could you take a look to:
https://wiki.documentfoundation.org/QA/FirstSteps ?

1) Try to rename your LO directory profile and give a new try
2) Try to disable OpenGL and give a new try
3) Did you install any specific fonts? If yes, could you disable them and try again?
4) Do you have 1 or several monitors?
Comment 3 Massimo 2018-02-04 14:35:40 UTC
Only one monitor. Renaming LO profile did not change anything (new one created at startup, still crashing). Neither did the fact of sabling the only font I had added. But disabling OpenGL seems to do the job: I could open the file without crash.
Strange enough, on another PC (same OS and LO versions, but much older) I do not get the crash. The one on which I have problems is has a couple of months of "age" (I can paste here the configuration, if that may help).
Comment 4 Julien Nabet 2018-02-04 20:04:29 UTC
(In reply to Massimo from comment #3)
> Only one monitor. Renaming LO profile did not change anything (new one
> created at startup, still crashing). Neither did the fact of sabling the
> only font I had added. But disabling OpenGL seems to do the job: I could
> open the file without crash.
> Strange enough, on another PC (same OS and LO versions, but much older) I do
> not get the crash. The one on which I have problems is has a couple of
> months of "age" (I can paste here the configuration, if that may help).
Thank you for your feedback!
On the pc which crashes, could you check you got the last drivers of your graphic card? If there's some upgrade, could you do it and give a new try with OpenGL enabled?

In both cases, if you still reproduce this, could you attach  <user profile>/cache/opencl_devices.log ?
Comment 5 Massimo 2018-02-04 21:33:54 UTC
I have just updated the display driver (Intel HD Graphics 630), from Device Manager. I have then turned on again OpenGL but the crash appeared again. Below is the log you asked for. Tomorrow I'll check on another desktop (the one I have at office) and report whether it crashes as well or not.

Device Index: 0
  Selected: true
  Device Name: Intel(R) HD Graphics 630
  Device Vendor: Intel(R) Corporation
  Device Version: OpenCL 2.1 
  Driver Version: 21.20.16.4839
  Device Type: gpu 
  Device Extensions: cl_intel_accelerator cl_intel_advanced_motion_estimation cl_intel_d3d11_nv12_media_sharing cl_intel_driver_diagnostics cl_intel_dx9_media_sharing cl_intel_motion_estimation cl_intel_packed_yuv cl_intel_required_subgroup_size cl_intel_simultaneous_sharing cl_intel_subgroups cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d10_sharing cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp16 cl_khr_fp64 cl_khr_gl_depth_images cl_khr_gl_event cl_khr_gl_msaa_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_gl_sharing cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_mipmap_image cl_khr_mipmap_image_writes cl_khr_spir cl_khr_subgroups cl_khr_throttle_hints 
  Device OpenCL C Version: OpenCL C 2.0 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: Intel(R) OpenCL
  Platform Vendor: Intel(R) Corporation
  Platform Version: OpenCL 2.1 
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_intel_dx9_media_sharing cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp64 cl_khr_gl_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_spir

Device Index: 1
  Selected: false
  Device Name: Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz
  Device Vendor: Intel(R) Corporation
  Device Version: OpenCL 2.1 (Build 2)
  Driver Version: 6.8.0.2
  Device Type: cpu 
  Device Extensions: cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_depth_images cl_khr_3d_image_writes cl_intel_exec_by_local_thread cl_khr_spir cl_khr_dx9_media_sharing cl_intel_dx9_media_sharing cl_khr_d3d11_sharing cl_khr_gl_sharing cl_khr_fp64 cl_khr_image2d_from_buffer 
  Device OpenCL C Version: OpenCL C 2.0 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: true
  Platform Name: Intel(R) OpenCL
  Platform Vendor: Intel(R) Corporation
  Platform Version: OpenCL 2.1 
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_intel_dx9_media_sharing cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_d3d11_sharing cl_khr_depth_images cl_khr_dx9_media_sharing cl_khr_fp64 cl_khr_gl_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_spir

icd cl_khr_image2d_from_buffer cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_spir
Comment 6 Julien Nabet 2018-02-05 07:47:59 UTC
(In reply to Massimo from comment #5)
> I have just updated the display driver (Intel HD Graphics 630), from Device
> Manager. I have then turned on again OpenGL but the crash appeared again.
> Below is the log you asked for. Tomorrow I'll check on another desktop (the
> one I have at office) and report whether it crashes as well or not.

Beware, there are OpenCL and OpenGL ("C" and "G") both are linked to the graphic card. For more details, I let you take a look to Wikipedia.
Could you attach the opengl_device.log by using the link 
https://bugs.documentfoundation.org/attachment.cgi?bugid=115428&action=enter
<user profile>/cache/opengl_device.log ?
Comment 7 Xisco Faulí 2018-02-05 09:19:49 UTC Comment hidden (obsolete)
Comment 8 Massimo 2018-02-05 09:41:41 UTC
Here is the content of opengl_device.log

DriverVersion: 21.20.16.4839
DriverDate: 10-19-2017
DeviceID: PCI\VEN_8086&DEV_5912&SUBSYS_86941043&REV_04
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5912
AdapterSubsysID: 0x86941043
DeviceKey: System\CurrentControlSet\Control\Video\{684EFBAD-BEE3-11E7-BBDC-D67E9235D507}\0000
DeviceString: Intel(R) HD Graphics 630

I'm going to try the master build and report later. I won't be able to check on office desktop today, I'm stuck at home because tram and bus are stopped in reaction to a driver being aggressed yesterday (nice place to live, uh?)
Comment 9 Massimo 2018-02-05 09:54:49 UTC
OK, the development version does not crash. Here are the details of the version I have installed.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 467d369081dcae359601e2baefed758bb50b28cf
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-02-05_04:02:41
Locale: en-GB (en_GB); Calc: CL

Hope it helps...
Comment 10 Massimo 2018-02-05 10:04:29 UTC
On the other hand, 6.0.1 still DOES crash!

Version: 6.0.1.0.0+ (x64)
Build ID: 6ff4bf9a2720b504e5134f5b34ac6c3b51fefd1f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-0, Time: 2018-02-05_00:45:17
Locale: en-GB (en_GB); Calc: CL
Comment 11 Gabriele Ponzo 2018-02-05 10:09:45 UTC
Same behavior for me:
Versione: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
Thread CPU: 4; SO: Linux 4.4; Resa interfaccia: GL; VCL: gtk2; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group

If I disable OpenGL then it doesn't crash any longer.


My configuration is:
elemenntary Os Freya
Linux 4.4.0-111-generic #134~14.04.1-Ubuntu SMP Mon Jan 15 15:39:56 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


No problem if I open it with this version (same PC):
Versione: 5.4.4.2
Build ID: 1:5.4.4~rc2-0ubuntu0.14.04.1~lo1.1
Thread CPU: 4; SO: Linux 4.4; Resa interfaccia: GL; VCL: gtk2; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group

cache dir under user profile is empty, but I may attach dump files under crash if you wish.

Going to try 6.1...
Comment 12 Gabriele Ponzo 2018-02-05 10:27:04 UTC
No problems with:
Version: 6.1.0.0.alpha0+
Build ID: 33f0eefd60c9f0ae56593583f094f025e00f3d35
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-04_23:51:32
Locale: it-IT (it_IT.UTF-8); Calc: group
Comment 13 Xisco Faulí 2018-02-05 10:28:14 UTC
Hi Massimo,
The patch is not in 6.0.1 yet, that's why it's still crashing in that version.
Not reproducing it on master means it's indeed fixed and a duplicate of bug 114736

*** This bug has been marked as a duplicate of bug 114736 ***
Comment 14 Massimo 2018-02-06 08:38:48 UTC
Crash confirmed also on my desktop PC. Here is the opengl_device log

DriverVersion: 23.20.15015.1002
DriverDate: 1-12-2018
DeviceID: PCI\VEN_1002&DEV_6611&SUBSYS_210B1028&REV_00
AdapterVendorID: 0x1002
AdapterDeviceID: 0x6611
AdapterSubsysID: 0x210b1028
DeviceKey: System\CurrentControlSet\Control\Video\{BF0D77BA-B7C4-11E7-A57D-64006A4D24B4}\0000
DeviceString: AMD Radeon(TM) R5 240

LO Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ja-JP (ja_JP); Calc: group