Bug Hunting Session
Bug 115442 - maximum number of consecutive hyphens not working
Summary: maximum number of consecutive hyphens not working
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack, needsDevEval
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2018-02-04 15:10 UTC by omarcibrario
Modified: 2018-09-08 23:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omarcibrario 2018-02-04 15:10:44 UTC
Description:
The system seems does not save when I put the "maximum number of consecutive hyphens"
I modified the default style that I use and I put number 1 of "maximum number of consecutive hyphens" (I only use the default settings style)
It works immediately when I do it, so t I save it properly. 
When I open the saved file the number of "maximum number of consecutive hyphens"  goes back to "0" and so change all the text inside the file.
There is not way to fix it in language setting because there is not that voice to mark.
The program does not keep the number that I want to fix.
I tried so many ways during 6 hours of research online even in Libreoffice Guide and nothing works.
Help please!

Actual Results:  
Open default setting style,
Check the box of automatic hyphenation,
Set the top line 3 and bottom line 2 (working correctly),
Change maximum number of consecutive Hyphens set to 1(working correctly),
Save as RTF.
Open the file saved
Maximum number of consecutive hyphens goes back in automatic to "0" and the text is totally unsaved as previous job looked in the screen


Expected Results:
Fix the problem


Reproducible: Always


User Profile Reset: No



Additional Info:
I use Windows 10 on Asus portable pc. I save the file in RTF or DOC


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 omarcibrario 2018-02-04 15:22:48 UTC
OPEN GL VIEWER

Renderer: Intel(R) HD Graphics 630
Vendor: Intel
Memory: 1024 MB
Version: 4.4.0 - Build 21.20.16.4550
Shading language version: 4.40 - Build 21.20.16.4550
Comment 2 Manuj Vashist 2018-02-06 16:12:37 UTC
Bug Reproducable on:
Version: 6.1.0.0.alpha0+
Build ID: 64d4f117447d990ed3215b0dd619e07de26ce417
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-IN (en_IN); Calc: group threaded

steps to reproduce:
1)open Format->paragraph->Text flow.
2)set Hypenation automatically and increase increase "Maximum number of consecutive hyphens" to any no.
3)Save the file.
4)open the same file and that increased no is set to 0 again.
Comment 3 omarcibrario 2018-02-07 03:48:43 UTC
do not consider it because it has been resolved
Comment 4 Thomas Lendo 2018-09-08 23:14:58 UTC
Not reproducible.

Version: 6.2.0.0.alpha0+
Build-ID: 9a9b81c7212fa6a6762246593acf3f1950677a22
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: threaded
from yesterday's Linux updater build

Closing as WORKSFORME.