Bug 115485 - UI: issue with Fill Cells commands in Row and Column split buttons
Summary: UI: issue with Fill Cells commands in Row and Column split buttons
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0
Keywords: difficultyBeginner, easyHack, skillDesign
Depends on:
Blocks: Split-Group-Buttons
  Show dependency treegraph
 
Reported: 2018-02-06 10:12 UTC by Thomas Lendo
Modified: 2019-02-27 18:44 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Fill Cell commands (yellow) in button menu (26.05 KB, image/png)
2018-02-06 10:12 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-02-06 10:12:56 UTC
Created attachment 139625 [details]
Fill Cell commands (yellow) in button menu

Click in a cell somewhere in a spreadsheet and click at the Row or Column button in the standard toolbar of Calc (on the right of "Spelling" button). You can see several items named Up, Down, Left, Right ...

These items are not self-explanatory. Only if you know that the same items exists in the Sheet > Fill Cells... sub-menu then you know what they mean. (Same in German language and very likely in most other localizations.)

2 suggestions:
- Extend the description of the items so that they have meaningful names even if they're used without a sub-menu.
- Insert the "Fill Cells" description above of these items as non-clickable text to describe what the items below are for.
Comment 1 Heiko Tietze 2018-02-27 09:08:47 UTC
(In reply to Thomas Lendo from comment #0)
> These items are not self-explanatory.

Yes, could also mean "Move up"

> 2 suggestions:
> - Extend the description of the items so that they have meaningful names
> even if they're used without a sub-menu.

Like "Extend down" or better have a submenu "Auto extend" with up/down... below?

> - Insert the "Fill Cells" description above of these items as non-clickable
> text to describe what the items below are for.

Don't get this. You have a special menu item in mind?
Comment 2 Thomas Lendo 2018-03-27 19:09:57 UTC
(In reply to Heiko Tietze from comment #1)
> (In reply to Thomas Lendo from comment #0)
> > - Insert the "Fill Cells" description above of these items as non-clickable
> > text to describe what the items below are for.
> Don't get this. You have a special menu item in mind?
I don't think it's wanted or good usability (as it's not self-explanatory and known by users), but I thought about a menu item that is not clickable but only for information, like non-active/greyed out items. This item would describe the following command items. I don't know if this already exists in LO or another program. Can't remember.
Comment 3 Heiko Tietze 2018-03-28 19:14:20 UTC
Discussed the issue in the design meeting. Move would be wrong as it is Fill (available in Sheet > Fill Cells > Up/Down...). But better we remove the options from the toolbar menu as there is not much benefit.
Comment 4 Cor Nouws 2018-04-04 09:04:54 UTC
(In reply to Heiko Tietze from comment #3)
> Discussed the issue in the design meeting. Move would be wrong as it is Fill
> (available in Sheet > Fill Cells > Up/Down...). But better we remove the
> options from the toolbar menu as there is not much benefit.

Why is there not much benefit in functions in a tool bar?
Without further argument, one could read it as an argument against tool bars in general  :D
I think more rationale is that the Fill function is a bit lost in between Row insert, Delete, Hide, Height ..
Comment 5 V Stuart Foote 2018-04-04 13:50:59 UTC
(In reply to Cor Nouws from comment #4)
> I think more rationale is that the Fill function is a bit lost in between
> Row insert, Delete, Hide, Height ..

Well the cause is that the text label for the  cell fill .uno commands do not include the "Fill". It is not needed as on the Sheet menu they are gathered into a "Fill Cells" sub menu where lack of the label for the action is correct.

But for the toolbar Split buttons for Rows and Columns, the button action for each  fill.uno command stands naked (but inside separators). 

They either need to pushed down further into a "Fill Cells" split button, or the separator needs label annotation "Fill Cells" since we probably should not change the .uno command labels.

The toolbar buttons *are* useful/appropriate in the Rows & Columns split buttons. Labeling the separator if possible seems better than pushing the action down a level further with another split button, either is better than simply removing them from toolbar.
Comment 6 Heiko Tietze 2018-04-07 15:27:57 UTC
(In reply to V Stuart Foote from comment #5)
> The toolbar buttons *are* useful/appropriate in the Rows & Columns split
> buttons. 

Do you have a good use case for this function, ideally one that is frequently used being the prerequisite for toolbar actions?
Comment 7 V Stuart Foote 2018-04-07 19:28:01 UTC
The Group buttons for Column and Row actions were added as popupmenus to the Calc standard toolbar resolving bug 86083 [1]; but the Fill actions used the existing .uno commands [2] in column_operations.xml and row_operations.xml menuitems with no labeling--so looks like they instead draw from the Context menu entry for their menu label. 

So, again either the Fill actions need to merged into a group button for each of the menus or they need some annotation in the xml menu--which ever is feasible.

=-ref-=
[1] https://gerrit.libreoffice.org/#/c/27570/
[2]".uno:FillUp",".uno:FillDown",".uno:FillLeft",".uno:FillRight",".uno:FillSeries",".uno:RandomNumberGeneratorDialog"
Comment 8 Heiko Tietze 2018-04-09 09:04:21 UTC
(In reply to V Stuart Foote from comment #7)
> The Group buttons for Column and Row actions were added as popupmenus to the
> Calc standard toolbar resolving bug 86083 [1];...

Still don't see a use case for the commands. What I mean is, when there is a use case it's likely nothing for many. Jay modified the menus to have _all_ commands available there, but that's not a good reason to clutter the toolbar. We have now a splitbutton with a few meaningful functions and some that are not needed. Renaming makes it more clear but without a use case I vote for removing it.
Comment 9 Mike Kaganski 2018-12-25 11:35:41 UTC
https://gerrit.libreoffice.org/65603 is an attempt to handle the issue.

But as I see, here is no agreement about the way to handle this properly.
The options vocalized are:

1. Naming the top separator of the group, so the relevant fragment of the Row button's drop-down would look like
> ...
> --- *Fill Cells* --- (here we insert the caption text to the separator!)
> Up [questionable in Row button drop-down]
> Down [questionable in Row button drop-down]
> Left
> Right
> Random Number...
> --------------------
> ...
This keeps the existing UNO command labels.

2. Changing labels to the commands, so that they look like this:
> ...
> --------------------
> Fill Up [questionable in Row button drop-down]
> Fill Down [questionable in Row button drop-down]
> Fill Left
> Fill Right
> Fill Random Number...
> --------------------
> ...

3. Removing the elements from the drop-down completely (on the grounds that there's no use case for them in the drop-down).

I should disagree with the lack of use cases. Unless we remove those elements from the Sheet->Fill Cells submenu, of course. Users may fill cells by double-clicking the cell drag handle; or by using the said submenu; or now using the drop-down button. *If* the function makes sense at all, I disagree that removing it from the (not cluttered!) drop-down intergating relevant functions is a good move.
Comment 10 Mike Kaganski 2018-12-25 12:54:23 UTC
For completeness: alternatively the items in column_operations.xml/row_operations.xml could be replaced by the ".uno:FillCellsMenu" submenu from sc/uiconfig/scalc/menubar/menubar.xml.
Comment 11 Commit Notification 2018-12-30 10:28:34 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4db55ce4c677f0193d7833042ab7529a0e82db2f%5E%21

tdf#115485 Add labels to fill items in Calc menu

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 BogdanB 2019-01-29 15:48:42 UTC
Fixed.

Verified on
Version: 6.3.0.0.alpha0+
Build ID: 9bc10964f0673b64e282ad567d08bf7ebba4df65
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-27_18:08:30
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded