Bug 115524 - FILEOPEN Track Changes does not show the change in number of added numbered paragraphs
Summary: FILEOPEN Track Changes does not show the change in number of added numbered ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.0.beta2
Keywords:
Depends on:
Blocks: Track-Changes-Lists
  Show dependency treegraph
 
Reported: 2018-02-07 18:03 UTC by Gabor Kelemen (allotropia)
Modified: 2022-06-29 12:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example data source file made with LO 5.4 (9.52 KB, application/vnd.oasis.opendocument.text)
2018-02-07 18:03 UTC, Gabor Kelemen (allotropia)
Details
The file in LO 5.4 (861.78 KB, image/jpeg)
2018-02-07 18:03 UTC, Gabor Kelemen (allotropia)
Details
screenshot of the fixed test document (16.98 KB, image/png)
2022-06-29 11:32 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-02-07 18:03:26 UTC
Created attachment 139669 [details]
Example data source file made with LO 5.4

Example file from LibreOffice 5.4
Writer does not show the change in serial numbers in numbered lists.

Steps to reproduce:
1. Create a numbered list in LibreOffice Writer.
2. Record Track Changes. (Ctrl - Shift - E)
3. Create a new element in the list.

Actual results:
Writer does not make crossline for old serial numbers 3.
Writer does not show that serial number 3. and 4. are new.

Expected results:
Writer shows the changes for serial numbers correctly.
Comment 1 Gabor Kelemen (allotropia) 2018-02-07 18:03:58 UTC
Created attachment 139670 [details]
The file in LO 5.4
Comment 2 Aron Budea 2018-02-14 01:44:47 UTC
I think it makes sense to handle both addition and deletion in the same bug report, so let's mark this one as duplicate as well.

*** This bug has been marked as a duplicate of bug 42748 ***
Comment 3 Commit Notification 2018-07-14 09:54:12 UTC Comment hidden (no-value)
Comment 4 Commit Notification 2018-07-14 09:55:30 UTC Comment hidden (no-value)
Comment 5 Olivier Hallot 2018-07-14 11:16:41 UTC Comment hidden (no-value)
Comment 6 Commit Notification 2018-07-14 11:20:52 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=739c3a473815ec31c9e5536ade28a6b0d011a572&h=libreoffice-6-1

tdf#115524 Some branch bookmarks are not working 2
Comment 7 Commit Notification 2018-07-14 11:22:12 UTC Comment hidden (no-value)
Comment 8 Timur 2019-11-15 17:19:04 UTC
Now that Bug 42748 is fixed in LO 6.4, this wasn't, but it's possible now. I set New again.
Comment 9 stragu 2021-12-30 06:59:18 UTC
I see this partially fixed since a few versions back.

Opening attachment 139669 [details]:
- number 3 is underlined
- adding a new 4th item will underline the whole line
- however, the change of numbering in subsequent items is not shown (only shows the new number, not the old one).

Version: 7.0.6.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.6-0ubuntu0.18.04.1_lo1
Calc: threaded

However, in version 7.3.0, the behaviour is different: the previous number (number 2) is highlighted instead of the corresponding one (number 3).

Version: 7.3.0.1 / LibreOffice Community
Build ID: 840fe2f57ae5ad80d62bfa6e25550cb10ddabd1d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 10 Xisco Faulí 2022-05-03 11:35:16 UTC
Dear László Németh,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 11 Commit Notification 2022-06-28 11:47:55 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d0e49c07203c9ae33c5dfa1855b2b8909c3e16dc

tdf#115524 sw_redlinenum: show original numbering of insertions

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 NISZ LibreOffice Team 2022-06-29 06:43:41 UTC
Verified in:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 51bfd4a3105e4a406dc8f220102520202a72150a
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 13 László Németh 2022-06-29 11:32:50 UTC
Created attachment 181013 [details]
screenshot of the fixed test document
Comment 14 Commit Notification 2022-06-29 12:32:48 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/508ed558948353a3eb8be9adf3588368e440f4cf

tdf#115524 sw_redlinenum: show original numbering of insertions

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.