Download it now!
Bug 115536 - Calc - Input line - Drag'n'drop doesn't work leftwise since LO6
Summary: Calc - Input line - Drag'n'drop doesn't work leftwise since LO6
Status: RESOLVED DUPLICATE of bug 114675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-08 06:10 UTC by Mike
Modified: 2018-02-08 10:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2018-02-08 06:10:10 UTC
Description:
I’m new to Calc, but maybe I found an issue. It’s about the drag n drop in the input line. If you drag a number or word to the left, it gets always get duplicated, too. Calc shifts the word or number to the right, that needs to be shifted, but keeps the dragged number/word also in its old place!

If you drag a word or number to the right, this issue is not present.

Steps to Reproduce:
1. Start Calc.
2. Click on the input line.
3. Enter “11111 22222” (without quotation marks)
4. Doubleclick on “22222” to select it
5. Drag that number to the left of “11111” (I mean to the beginning of the input line).
-> You get “22222122222“ instead of ” 2222211111”
-> “22222” stands at the beginning of the input line, but the number also stays at the old position. Calc overwrites the last four 1s with 2s.

6. Now enter “11111 22222” again.
7. Doubleclick on “11111”.
8. Drag it to the right position of “22222” (the end of the input line).
->  You get “ 2222211111“ (with a blank space at the beginning). That is correct.

Actual Results:  
see above

Expected Results:
see above


Reproducible: Always


User Profile Reset: No



Additional Info:
The issue also works with letters.
Enter „Abcde Fgh“ and drag „Fgh“ to the beginning of the input line. You get „FghAbcFgh“ instead of „FghAbcde“. The other way round works. If you drag „Abcde“ to the end of the line, you’ll get „ FghAbcde“

Enter „Lorem Ipsum Dolor“ and drag „Dolor" to the left of „Ipsum“. You get „Lorem DolorIDolor“.

It must be regression. The issue does not appear with LO 5.4.2.2

Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

Version: 6.1.0.0.alpha0+ (x64)
Build ID: b1069ea6f25daa268eb4358d5ea20094b46ef347
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-02-06_23:49:25
Locale: de-DE (de_DE); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Xisco Faulí 2018-02-08 10:41:56 UTC
Thanks for reporting the issue.
Indeed, it's a regression introduced by f1becd5d1c2d680c597b060fd87c211c7cefe434, which is also reported in bug 114675.
Closing as RESOLVED DUPLICATED.
Regards

*** This bug has been marked as a duplicate of bug 114675 ***