Bug 115548 - Base locks up
Summary: Base locks up
Status: RESOLVED DUPLICATE of bug 114676
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2018-02-08 14:07 UTC by tim
Modified: 2018-02-12 03:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

A sample database (3.46 KB, application/vnd.oasis.opendocument.database)
2018-02-08 22:05 UTC, tim

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2018-02-08 14:07:59 UTC
I upgraded to LO 6 as a trial (both directly, and via the ubvuntu 17.10 prerelease ppa). On opending my existing Base files that link to Mysql databases requiring password, it did not ask for the password, and was unresponsive.  I had to kill it.  I tried this in both ubuntu (Xorg) and ubuntu (wayland).

Steps to Reproduce:
1.Open a Base file that access Mysql requiring a user name and password
2.The file opens but is unresponsive to any user input

Actual Results:  
I had to kill it

Expected Results:
Should open and ask for username and password

Reproducible: Always

User Profile Reset: Yes

Additional Info:
I tried changing the database access method (using 5.4.4) from Mysql(Native) to Mysql(jdbc) with no success.

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36
Comment 1 tim 2018-02-08 14:11:34 UTC
The full version (as downloaded, not the ubuntu prerelease ppa version) is: 

Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group

I'm not sure how to provide an example, since all my mysql databases require a user name and password, and would require yourselves to create a similar database.  If I find any other way to demonstrate this I will add a post to the report.
Comment 2 tim 2018-02-08 17:48:27 UTC
I have found out why Base locks up.

If most of my databases, I have a macro run when the database is opened, containing:

    If Not ThisDatabaseDocument.CurrentController.IsConnected Then 
    End If

I do this and then open the first form I want to see (often a form selection form).

In the Connect locks up and doesn't ask me for the user name and password.  Commenting this code out, and not trying to open a form at the start, it works.  When I then manually open the first form it does ask me for a user name and password.

So this is not a stopper for me, just a nuisance :-)
Comment 3 tim 2018-02-08 22:05:55 UTC
Created attachment 139710 [details]
A sample database

This database demonstrates the problem.  With previous versions of LO Base the document opens and asks for the user name and password.  With version 6 it locks up.

The fact that the underlying mysql database doesn't exist on your systems shouldn't matter for the purpose of showing that Base now locks up on the connect statement in the DBOpen macro.
Comment 4 tim 2018-02-09 20:16:44 UTC
I just test version, and the problem persists.

Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 5 Stang 2018-02-12 03:59:30 UTC

*** This bug has been marked as a duplicate of bug 114676 ***