Download it now!
Bug 115551 - The translated strings (e.g. Gallery, Area, Image) in sidebar does not update in new releases
Summary: The translated strings (e.g. Gallery, Area, Image) in sidebar does not update...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-08 15:06 UTC by Cheng-Chia Tseng
Modified: 2019-04-09 03:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of "Gallery" in traditional Chinese langauge, which is "畫廊" in 6.0. (232.19 KB, image/png)
2018-02-08 16:14 UTC, Cheng-Chia Tseng
Details
Screenshot of "Area" and "Image" in traditional Chinese langauge, which is "區域" and "Image" in 6.0. (119.12 KB, image/png)
2018-02-08 16:16 UTC, Cheng-Chia Tseng
Details
gallery sidebar in linux version - ok (173.70 KB, image/png)
2018-02-09 13:12 UTC, Christian Lohmaier
Details
image sidebar section on linux - ok (104.98 KB, image/png)
2018-02-09 13:13 UTC, Christian Lohmaier
Details
Here is the screenshot of LibreOffice 6.0.0.3 on Windows platform showing the translation of Gallery. (92.08 KB, image/png)
2018-02-09 14:46 UTC, Cheng-Chia Tseng
Details
Here is the screenshot of LibreOffice 6.0.1 on Windows platform showing the translation of Gallery. (畫廊) (92.82 KB, image/png)
2018-02-09 18:00 UTC, Cheng-Chia Tseng
Details
Screenshot of "Gallery" in traditional Chinese langauge, which is "畫廊" in 6.0. Flatpak version on Linux (182.64 KB, image/png)
2018-03-04 03:36 UTC, Cheng-Chia Tseng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cheng-Chia Tseng 2018-02-08 15:06:18 UTC
Description:
The translation of "Gallery" in traditional Chinese has been all changed to "圖庫" from "畫廊" since the development stage of 5.3 release.

However, LibreOffice 5.4 and 6.0 does NOT update the translation as well.

Steps to Reproduce:
1. launch LibreOffice 5.4 or 6.0 and check the translation of "Gallery" in the sidebar

Actual Results:  
The translation of "Gallery" read as "畫廊." (Confirmed in 6.0 release with Win, Linux and Mac platform)

Expected Results:
The translation of "Gallery" should be updated to "圖庫." (Only 5.4 in Linux use "圖庫" as the translation while others don't)


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Cheng-Chia Tseng 2018-02-08 15:21:35 UTC
Gallery is one of the example. 

Others such as "Area" is changed as well in the development stage of LibreOffice 5.3, and is not updated in the sidebar either.
Comment 2 Cheng-Chia Tseng 2018-02-08 16:14:44 UTC
Created attachment 139698 [details]
Screenshot of "Gallery" in traditional Chinese langauge, which is "畫廊" in 6.0.
Comment 3 Cheng-Chia Tseng 2018-02-08 16:16:55 UTC
Created attachment 139699 [details]
Screenshot of "Area" and "Image" in traditional Chinese langauge, which is "區域" and "Image" in 6.0.

Screenshot of "Area" and "Image" in traditional Chinese langauge, which is "區域" and "Image" in 6.0. 

Area should be changed into "區塊" while Image should be "影像" as in the Pootle.
Comment 4 sophie 2018-02-08 16:31:39 UTC
Adding direct link to Pootle:
Translation of Gallery not updated in UI
https://translations.documentfoundation.org/zh_TW/translate/#search=LAb2y&sfields=notes
Translation of Image, still in English in UI
https://translations.documentfoundation.org/zh_TW/translate/#search=vnPii&sfields=notes
Translation of Area not updated in UI
https://translations.documentfoundation.org/zh_TW/translate/#search=4FE4o&sfields=notes

Adding Christian in cc, could you have a look at it? Thanks
Comment 5 Christian Lohmaier 2018-02-09 13:11:47 UTC
worksforme.

please show full output of

rpm -qa|grep -e libreoffice -e liboboasis|sort
Comment 6 Christian Lohmaier 2018-02-09 13:12:46 UTC
Created attachment 139729 [details]
gallery sidebar in linux version - ok
Comment 7 Christian Lohmaier 2018-02-09 13:13:24 UTC
Created attachment 139730 [details]
image sidebar section on linux - ok
Comment 8 sophie 2018-02-09 13:16:46 UTC
In his message on l10n, Cheng-Chia said that Linux is ok while other platform not:
"There are only LibreOffice 5.4 on Linux platform and LibreOffice 6.0 RC on
Linux platform were changed as expected. But, LibreOffice 6.0 on ALL
platforms does not use the existing translations."

Full message is here: http://nabble.documentfoundation.org/libreoffice-l10n-The-change-of-the-translated-strings-does-not-update-in-recent-releases-tp4232433.html
Comment 9 Christian Lohmaier 2018-02-09 13:56:05 UTC
the screenshots with the problem show linux though, HW/OS are set to ALL, bug was filed using linux, description says all platforms for 6.0 are affected.

Don't expect people to read different mailthreads when looking at a bugreport.
In any case, both the bug as well as the mail linked claim 6.0 on all systems would be affected, I cannot reproduce in current 6.0.1 version, so request for more info holds. Translations repo has new string for what it's worth, and as release builds are always done from-scratch I still suspect installation/individual problem.
Comment 10 Cheng-Chia Tseng 2018-02-09 14:46:32 UTC
Created attachment 139735 [details]
Here is the screenshot of LibreOffice 6.0.0.3 on Windows platform showing the translation of Gallery.
Comment 11 Cheng-Chia Tseng 2018-02-09 14:52:10 UTC
I installed the rpms provided by TDF site. 
Now I will try 6.0.1 and report the result later.
Comment 12 Kevin Suo 2018-02-09 15:48:35 UTC
Also try to make a backup of your user profile and run the test with a fresh new profile.
Comment 13 Cheng-Chia Tseng 2018-02-09 17:59:23 UTC
The result for 6.0.1 below, 

Linux, installed with the rpm provided by TDF site via the ./install script it provides.
1. if update with ./install script
   => the translation of the sidebar is not updated. (Not expected result)
2. if the existing folder deleted (the default installation folder of ./install script is ~/libreoffice), installed freshly
   => the translation of the sidebar is updated. (Expected result)

Windows, installed with the installer provided by TDF site.
1. double click the installer and finished the installation
   => the translation of the sidebar is not updated. (Not expected result)
2. remove the old installation, reboot, and then re-install.
   => the translation of the sidebar is not updated. (Not expected result)

Mac, installed with the installer provided by TDF site.
1. replace the old img
   => the translation of the sidebar is updated. (Expected result)

BTW, I don't know how to get a freshly installation on Windows. :S
The translation of the sidebar cannot be fixed with the methods above. I'm attaching the screenshot.
Comment 14 Cheng-Chia Tseng 2018-02-09 18:00:55 UTC
Created attachment 139743 [details]
Here is the screenshot of LibreOffice 6.0.1 on Windows platform showing the translation of Gallery. (畫廊)
Comment 15 Kevin Suo 2018-02-10 00:02:19 UTC
So it seems that the Windows installation failed to override the resource files? 

Set back to unconfirmed.
Comment 16 Cheng-Chia Tseng 2018-03-04 03:36:01 UTC
Created attachment 140322 [details]
Screenshot of "Gallery" in traditional Chinese langauge, which is "畫廊" in 6.0. Flatpak version on Linux
Comment 17 Cheng-Chia Tseng 2018-09-14 13:50:14 UTC
Now 6.1.1 is released.
Here is the investigation of the installation.

Mac: all correct
RPM packages via TDF release: all correct
DEB pacakges via TDF release: all correct
Windows: The translation of the Gallery is still "畫廊" instead of "圖庫."

Note: I have already installed an old version of LibreOffice on Windows. The test here is re-installed after the removal and restart.
Comment 18 Xisco Faulí 2019-03-14 20:52:13 UTC
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 19 Cheng-Chia Tseng 2019-04-09 03:29:59 UTC
Some users reported they see 圖庫 instead of 畫廊 in 6.2 on Windows, confirmed with screenshots.