Download it now!
Bug 115563 - Borders toolbar menu items do not display properly on hidpi screens
Summary: Borders toolbar menu items do not display properly on hidpi screens
Status: RESOLVED DUPLICATE of bug 107403
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-08 23:11 UTC by hvbakel
Modified: 2018-02-08 23:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot of the borders menu on a hidpi screen (70.79 KB, image/png)
2018-02-08 23:21 UTC, hvbakel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hvbakel 2018-02-08 23:11:56 UTC
Description:
When using libreoffice on a hidpi screen (e.g. 3840x2160) with scaling set to 2x, the items in the borders toolbar menu are all clipped. This means it is not possible to differentiate between e.g. selecting top or bottom borders. This problem occurs for any component that uses the borders toolbar, such as cells in calc or tables in writer.

Steps to Reproduce:
1.Start libreoffice calc or writer on a hidpi display with scaling set to 2x
2.Create a table in writer and go to a cell, or select a cell in calc
3.Click on the 'borders' button in the toolbar

Actual Results:  
The popup with the different border configurations shows the exact same image (a blank square) for all outer-border options. Only the bottom row with inner border options provides some information.

Expected Results:
Each square in the borders popup should show a different border selection option.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The scaling issue is apparent regardless of the icon theme that is selected.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36
Comment 1 hvbakel 2018-02-08 23:21:23 UTC
Created attachment 139711 [details]
Screenshot of the borders menu on a hidpi screen

Attachment showing the defective border menu on a hidpi screen.
Comment 2 Maxim Monastirsky 2018-02-08 23:43:46 UTC
Looks like the same problem as in Bug 107403.

*** This bug has been marked as a duplicate of bug 107403 ***