Bug Hunting Session
Bug 115603 - FILESAVE: Group shape (triangle) in PPTX is shifted down upon save
Summary: FILESAVE: Group shape (triangle) in PPTX is shifted down upon save
Status: RESOLVED DUPLICATE of bug 91999
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ooxml
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2018-02-10 01:57 UTC by Aron Budea
Modified: 2018-09-09 23:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX (29.54 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-02-10 01:57 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-02-10 01:57:43 UTC
Created attachment 139748 [details]
Sample PPTX

Open, save and reopen the attached PPTX having a triangle shape.

=> Triangle is shifted down.

In ppt/slides/slide1.xml, the values change upon save as follows:

Original:
<a:xfrm rot="10800000" flipH="1">
  <a:off x="1892386" y="1683327"/>
  <a:ext cx="1983423" cy="1652153"/>
</a:xfrm>

Saved:
<a:xfrm flipH="1" rot="10800000">
  <a:off x="2307600" y="3166560"/>
  <a:ext cx="247320" cy="83880"/>
</a:xfrm>

Observed using LO 6.0.0.3 / Windows 7.
In 5.4.0.3 the result was worse: the shape is also shifted horizontally.

The horizontal shift got fixed by the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602
author		Szymon Kłos <szymon.klos@collabora.com>	2017-10-24 22:39:08 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-10-26 08:02:13 +0200

PPTX export: correct position of rotated groups
Comment 1 Jacques Guilleron 2018-02-10 13:46:47 UTC
Hi Aron,

I confirm this shifting with
LO  6.0.0.3 Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
with these values when saved:

-<a:xfrm rot="10800000" flipH="1">
<a:off y="3335400" x="1891800"/>
<a:ext cy="1651680" cx="1983240"/>
Comment 2 Jacques Guilleron 2018-02-10 14:14:19 UTC
This shifting occurs also with
LO 3.5.3.2 Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
under Windows 7, so probably inherited from OOo.
Comment 3 Aron Budea 2018-09-09 21:29:07 UTC
Turns out this got fixed by the same commit as bug 91999, setting as duplicate.

*** This bug has been marked as a duplicate of bug 91999 ***