Download it now!
Bug 115637 - Conditional Formatting: OK, Cancel button not working (and UI objects misplaced) with Non-English UI
Summary: Conditional Formatting: OK, Cancel button not working (and UI objects misplac...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.beta1
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Dialog Conditional-Formatting-Editing
  Show dependency treegraph
 
Reported: 2018-02-12 01:53 UTC by Kevin Suo
Modified: 2020-01-03 15:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (39.02 KB, image/png)
2018-02-12 01:53 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2018-02-12 01:53:28 UTC
Description:
Conditional Formatting not working with Simplified Chinese UI.  The OK, Cancel buttons are not working on click. 

I also noticed that the UI elements are misplaced, which may be a different issue.

Steps to Reproduce:
1.Open Calc with Simplified Chinese UI. (I guess this may happen with other non-english UIs)
2. Select some cell ranges, then go to "Format > Conditional Formatting > Condition > (any of the sub-menu)
3. Set (or without setting) some conditions, then try to click OK (确认) or Cancel (取消)


Actual Results:  
No reaction with clicking on OK or Cancel.

Expected Results:
OK: Apply and close window;
Cancel: Close window without applying conditions.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.0.1.1
Build ID:60bfb1526849283ce2491346ed2aa51c465abfe6
CPU 线程:4; 操作系统:Linux 4.14; UI 渲染:默认; VCL: gtk2; 
区域语言:zh-CN (zh_CN.UTF-8); Calc: group

Fedora 27, GNOME Shell 3.26.2.


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Kevin Suo 2018-02-12 01:53:57 UTC
Created attachment 139804 [details]
screenshot
Comment 2 Kevin Suo 2018-02-12 01:56:38 UTC
Set priority to HIGH MAJOR as the core functionality is broken.

Adding Volga to cc list, if you have time, please help to test and confirm, thanks.
Comment 3 Kevin Suo 2018-02-12 02:07:40 UTC
Of course this is a regress.

Bug also exists in version 5.4.4.2 release.

Bibisecting is not possible due to the fact that none of the bibisect repo provides other langpacks.
Comment 4 Kevin Suo 2018-02-12 02:16:49 UTC
Bug also exits in the KeyID "language".

q8p26‖Version: 6.1.0.0.alpha0+
XZmEs‖Build ID: 4082a18406c18af7b4fcef7bd501c3679c3be56b
Dk4vc‖CPU threads: 2; 5DyEd‖OS: Linux 4.14; Yqrwo‖UI render: ZitRE‖default; VCL: gtk3; 
Ru2AA‖Locale: zh-CN (zh_CN.UTF-8); Calc: group threaded
Comment 5 Kevin Suo 2018-02-12 02:25:47 UTC
Bug already exists on the build I have at
6eeac3539ea4cac32d126c5e24141f262eb5a4d9 libreoffice-6-0-branch-point
Comment 6 Kevin Suo 2018-02-12 04:27:08 UTC
(In reply to Kevin Suo from comment #3)

Noted the for "5.4.4.2" release, I mean: 
版本:5.4.4.2
Build ID:5.4.4.2-4.fc27
CPU 线程:2; 操作系统:Linux 4.14; UI 渲染:默认; VCL: gtk3; 
区域语言:zh-CN (zh_CN.UTF-8); Calc: group

This is a build by Fedora. 

In the version I download from TDF, the bug does not exist in 5.4.4.2 and 5.4.5.1.
Comment 7 Kevin Suo 2018-02-12 05:09:09 UTC
libreoffice-6-0-branch-point is at the tag of libreoffice-6.0.0.0.beta1.
Comment 8 Kevin Suo 2018-02-12 08:01:05 UTC
Regression introduced by the following commit:

author	Bernhard Widl <bernhard.widl@cib.de> 2017-10-20 14:34:53 +0200
committer Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de> 2017-10-26 08:43:10 +0200
commit	cb151051d79a7ec176e769a33a56e7d906fc1425 (patch)
tree	fc6c2890b0cce32924934572569ce10a8ccc418b
parent	08a690cf66d4e798896b61aa5a7a81e81885cd0c (diff)
tdf#113444 removed capping of default font size

Adding Bernhard Widl to the cc list: would you please take a look?


-------------------------------

Blow are the bibisect log:

64c0802644ae8f66c9b2479e29dab0b1103ad302 is the first bad commit
commit 64c0802644ae8f66c9b2479e29dab0b1103ad302
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sun Oct 29 11:54:01 2017 +0100

    source sha:cb151051d79a7ec176e769a33a56e7d906fc1425
    
    source sha:cb151051d79a7ec176e769a33a56e7d906fc1425

:040000 040000 207569338305669788fdd2bba19f8ff03fb2e47a c8ed6c7bf6d5de72a427a61d1f08ad00ee2badb7 M	instdir

[suokunlong@x230i bibisect-linux-64-6.0]$ git bisect log
# bad: [cddc6665c4e33f5a18e7e1a02cd2799d95653f0a] source sha:47cc374c0659fd3db74a1b184c870eaa56bc385b
# good: [b9d78ce81dc3481fccb0cb75d76fcb6ac939cbd5] source sha:9feb7f7039a3b59974cbf266922177e961a52dd1
git bisect start 'master' 'oldest'
# good: [eb6680d85befc418b36f2cb00402f56a2472758f] source sha:c54850b23a8240a41755af171a6d3f990ee69f84
git bisect good eb6680d85befc418b36f2cb00402f56a2472758f
# good: [3fa1ae98ece9b3537df34742d3383aac834caf76] source sha:87c671d188f4a0f5dcc7944b450cc58e84217d81
git bisect good 3fa1ae98ece9b3537df34742d3383aac834caf76
# bad: [9bc1a6bd3e4aafadd3a19ac4983952db039716f9] source sha:bff8d843bd4e5dcca5dc1a60c2c7852b1b72a00b
git bisect bad 9bc1a6bd3e4aafadd3a19ac4983952db039716f9
# bad: [a953b1c0692258b21302b14bc5d7e624c24ba880] source sha:db378d64a9ca8675066fda31f3bd77dc37c52398
git bisect bad a953b1c0692258b21302b14bc5d7e624c24ba880
# bad: [7c316d96affb607e199132c13bd140e29187ed59] source sha:7e87403953dfd54bf1e904ccc7436c6f327a9069
git bisect bad 7c316d96affb607e199132c13bd140e29187ed59
# good: [b1e211a114e722288c7c2f8c592e0f0f8647a04e] source sha:57c512c4a3cffd069b30596642864368356c4038
git bisect good b1e211a114e722288c7c2f8c592e0f0f8647a04e
# good: [9142b3920dcda25dd5649ac952ca7c676226bd5d] source sha:4d65adb2fa02645e3c9e946a0b896af51ef27a7d
git bisect good 9142b3920dcda25dd5649ac952ca7c676226bd5d
# good: [fbbdd8c3d775574f145f1a7c9d97ffa59adc3221] source sha:d271ec87b8ec3264095a5265a7b0f1c073bc211b
git bisect good fbbdd8c3d775574f145f1a7c9d97ffa59adc3221
# good: [d98a3f9c99d7689fa7197488fe9cdf41dd91f277] source sha:dd0bc7323014c528fefb516cacae0591f270862a
git bisect good d98a3f9c99d7689fa7197488fe9cdf41dd91f277
# good: [33eda07a4761b5c81110518cc058d0de51fd8c33] source sha:08a690cf66d4e798896b61aa5a7a81e81885cd0c
git bisect good 33eda07a4761b5c81110518cc058d0de51fd8c33
# bad: [8977043bc38727f337dba48114079c8606a91549] source sha:aded98ce3d7a4189a4fa30989505da9427abc83b
git bisect bad 8977043bc38727f337dba48114079c8606a91549
# bad: [5eea56c750ffdca0c47adea10d8db86b4a8b10f5] source sha:b4e235a925b5c73a2220f57cdb8b85379fb3bac1
git bisect bad 5eea56c750ffdca0c47adea10d8db86b4a8b10f5
# bad: [64c0802644ae8f66c9b2479e29dab0b1103ad302] source sha:cb151051d79a7ec176e769a33a56e7d906fc1425
git bisect bad 64c0802644ae8f66c9b2479e29dab0b1103ad302
# first bad commit: [64c0802644ae8f66c9b2479e29dab0b1103ad302] source sha:cb151051d79a7ec176e769a33a56e7d906fc1425
Comment 9 Kevin Suo 2018-02-12 08:11:42 UTC
Just for the record, from bibisecting this bug, I now know how to bibisect locale-dependent bugs using the bibisect repos.

The TDF bibisect repos at [1] do not include any lang-packs. 

To bibisect bugs which work good in english UI, but bad in non-english UI (like CJKs): one should copy-paste the following files, from a release build which has your language, to the bibisect build locations:

1. program/resource/<your_lang_tag>
2. share/registry/Langpack-<your_lang_tag>.xcd
3. share/registry/res/fcfg_langpack_<your_lang_tag>.xcd
4. share/registry/res/registry_<your_lang_tag>.xcd

The suggested language resources you should copy is the one for the same major branch. For example, for the bibisect-linux-64-6.0 repo, I copied from 6.0.1.1 release.
Comment 10 Xisco Faulí 2018-02-26 13:06:36 UTC
@kevin, thanks for adding it to the wiki -> https://wiki.documentfoundation.org/QA/Bibisect#Bibisecting_language-specific_bugs
Comment 11 Lun 2018-11-29 09:20:05 UTC
Bug not reproducible in version 6.3.0.0.alpha0+ (x64)

Additional Info:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded

OS:Windows 10 Pro. 64-bit x64
Comment 12 QA Administrators 2019-11-30 03:40:10 UTC
Dear Kevin Suo,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug