Download it now!
Bug 115751 - Improvement Suggestions for LibreOffice AutoCorrect Function Word Completion
Summary: Improvement Suggestions for LibreOffice AutoCorrect Function Word Completion
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2018-02-15 16:20 UTC by J. Schulte
Modified: 2018-03-12 21:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J. Schulte 2018-02-15 16:20:01 UTC
Description:
My Improvement Suggestion for the LibreOffice AutoCorrect Function Word Completion

Steps to Reproduce:
Dear LibreOffice Team

I would like to suggest a suggestion for the LibreOffice Writer, which I would be very happy if you could fulfill them in the upcoming release.

Proposal number 1 is a revision of the "AutoCorrect Function Word Completion", which stores words that are longer than six letters and adds them as needed. Example: "LibreOffice", the word has more than six letters, which is why the word completion remembers the word and saves it for a new need. The second time you need to write only "Libr" and the word extension proposes "LibreOffice" before and pressing the enterkey is "LibreOffice" in the text.

I come now to my suggestion, because the word supplement also remembers words that occur only once in the text, so that words that occur more often in the text and much more typed are not even suggested first, which I think is a pity because I have this Use the function daily. The word supplement needs to be further developed so that it remembers words that occur more often in the text than once and then never again. In addition, the word completion remembers spelling mistakes or typos, such as "Sie geht heute nach Hause. Er geht nach Hause." If you hit "Zuhause" now, the word "Zuhause." Suggests what's no advantage, because it's grammatically wrong, as well also words with numbers are wrong. For example, one wanted to write "verlassen" but instead one accidentally "verliert" remembering the word completion, even though it is completely wrong, and yet the wrong word is always suggested first.

I offer that the word completion be reprogrammed, that the word completion will not remember any words with dots, hyphens, typos and spelling errors, because nobody needs words like "Zuhause .", "Auto" Cellar, example. Verlie0en, gro0 "Der Bindestrich sollte auch beim Wortzusatz ignoriert werden, wenn die Wörter dort enden, denn Wörter wie" sick, police and fire trucks "are abbreviations in the German language because they would not have to write out and rather become themselves That's why I ask that the word supplement no longer suggests this in the future.

Thank you for your attention and look forward to the upcoming releases of LibreOffice.

Yours sincerely, J. Schulte

Actual Results:  
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
 


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Xisco Faulí 2018-02-19 09:39:34 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 2 V Stuart Foote 2018-03-07 17:58:40 UTC
Defaults will populate the Word Completion item set with a default minimum word length of 8 characters, not 6.

And the word completion trigger starts at 3 characters and pulls from the SfxItemSet of the OfaAutoCompleteTabPage [1] _alphabetically_. 

For example using the dummy text (DT) autotext fill, typing "dea" will return "dead-end" rather than "deadbeat". Continuing to type "deadb" will move to the next entry.

Adding additional complexity: to detect typos, grammar, or even word frequency to the mix would not add much function--but would impose considerable overhead to the current collect & match processes.

Seems the only real enhancement to be had would be to provide a means to move within the match list and pass over a not desired/bad entry, and see the next match, or to then move back.

Maybe even to delete a bad entry from there, without having to reopen the AutoCorrect dialog -> Word Completion tab.

As presented => WF

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/cui/source/tabpages/autocdlg.cxx#2240