Bug 115755 - Printing with Calc: Blank box on top of page
Summary: Printing with Calc: Blank box on top of page
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2018-02-15 16:39 UTC by ds
Modified: 2019-11-09 13:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test file where the blank box error appears (17.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-02-15 16:42 UTC, ds
Details
gdb bt (5.58 KB, text/plain)
2019-10-18 20:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ds 2018-02-15 16:39:54 UTC
Description:
Printing preview looks OK, Exporting as PDF looks OK, Sending to printer results in blank box on top of the page (also the small preview in the print window).

Tested with v5.4.3.2, v5.5.4, v6.0.1, same results.

Steps to Reproduce:
1. Please download test file from https://www.file-upload.net/download-12980655/test.ods.html
2. Open with Calc
3. Open print dialog, you will see a big blank box which overlays the content.
4. For comparison, please also try exporting to PDF which works fine.

Actual Results:  
Blank box is shown.

Expected Results:
Content should be printed like it works fine with PDF export.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.4.3.2
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 ds 2018-02-15 16:42:20 UTC
Created attachment 139929 [details]
test file where the blank box error appears

This is the test file.
It was converted from XLSX format (but same result with both formats).
Comment 2 Xavier Van Wijmeersch 2018-02-15 20:52:56 UTC
confirm with

Version: 6.0.2.0.0+
Build ID: df72c65fdaf5f1276d1759ba3e7eec83eaaa2d20
CPU threads: 2; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2018-02-15_02:20:53
Locale: nl-BE (en_US.UTF-8); Calc: group

also with master
Comment 3 Telesto 2018-02-16 09:10:28 UTC
Repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 QA Administrators 2019-02-17 03:44:16 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-02-18 15:52:11 UTC
Repro 6.3+ in Win. Repro 4.1 no 4.0. Seems regression.
Comment 6 Timur 2019-10-15 14:16:26 UTC
Using 41max I get this (but not sure what it means):

dadd589cd0633db4e126f0a6ab2907ffeef34563 is the first bad commit
commit dadd589cd0633db4e126f0a6ab2907ffeef34563
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 10:13:10 2015 +0800

    source-hash-bb3f2900a867fdcb6df916fff58199b4ce94dd05
    
    Bibisect: This commit covers the following source commit(s) which failed to build
    34e79c19babc0e6cc281025b40635b91dca444f3
    542ad7f1c5ac7794c42248ac13e9b33f84888490
    a108f4b14e119736c6a24f00cbfe87acb71e1e4a
    f828e91d1b2f0491e3d1c724ddd12f1b9177f466
    97b583a7bfb5dc9000290c3bdc8df8751a97d65d
    355c30789e311aa13d7421ce653dc80a9030c2e2
    
    commit bb3f2900a867fdcb6df916fff58199b4ce94dd05
    Author:     Michael Meeks <michael.meeks@suse.com>
    AuthorDate: Mon Dec 17 19:55:32 2012 +0000
    Commit:     Michael Meeks <michael.meeks@suse.com>
    CommitDate: Mon Dec 17 19:57:54 2012 +0000
    
        fdo#58399 - revert attempts to untangle and accelerate this mess.
    
        Reverts commits:
            76350361f386b78e1bc9edb75af89e7ff3afe356
            67f899e1d2db0dccde4b9587a52b7157fe1fb0be
            1d77d4eada214e14938336070b248c18705939ff
            1d16f59023b1b19d01ca69b8c9735be6d3baf5d9
    
        The bug has a great series of linked bugs and stack-traces; the
        weakref / mixed tools & UNO lifecycle here is simply hideous.

:040000 040000 99f15e051caeacf933d5bb1f0749720ffa4131ca dd73dfa370efeb20fb22ef3f616d7256824e689a M	opt
Comment 7 Timur 2019-10-15 14:34:06 UTC
Apart from Michael's https://gerrit.libreoffice.org/plugins/gitiles/core/+/bb3f2900a867fdcb6df916fff58199b4ce94dd05 , these also look suspicious to me: 


https://gerrit.libreoffice.org/plugins/gitiles/core/+/f828e91d1b2f0491e3d1c724ddd12f1b9177f466

commit	f828e91d1b2f0491e3d1c724ddd12f1b9177f466	[log]
author	Noel Power <noel.power@suse.com>	Mon Dec 17 17:49:00 2012 +0000
committer	Noel Power <noel.power@suse.com>	Mon Dec 17 17:49:00 2012 +0000
tree	7b5739067e7732a09ed67693523123b618a3aa6d
parent	a108f4b14e119736c6a24f00cbfe87acb71e1e4a [diff]

fix problematic calc object selection after object create  (at non 100% zoom)

sometimes difficult to select custom shapes etc. created at non 100% zoom
levels. workaround was to use selection tool to select an area.

Change-Id: I112a60ebf37a37b16f6af5e70358853088e648a8


https://gerrit.libreoffice.org/plugins/gitiles/core/+/97b583a7bfb5dc9000290c3bdc8df8751a97d65d

commit	97b583a7bfb5dc9000290c3bdc8df8751a97d65d	[log]
author	Kohei Yoshida <kohei.yoshida@gmail.com>	Mon Dec 17 11:57:06 2012 -0500
committer	Kohei Yoshida <kohei.yoshida@gmail.com>	Mon Dec 17 12:55:40 2012 -0500
tree	de102bd416e30823b2be4f09e061936c9ecdce03
parent	f828e91d1b2f0491e3d1c724ddd12f1b9177f466 [diff]

Change the order of always, never, ask enumerations.

This tri-state option is commonly ordered ask-always-never or
always-never-ask, but not always-ask-never, which is not very common.

Change-Id: Ie3a3d1b40397b5cd7d28e64948a2b946bb619b49
Comment 8 Timur 2019-10-18 07:55:49 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2019-10-18 11:25:25 UTC
(In reply to Timur from comment #8)
> Xisco, how do we know which is the exact commit?

well, if you can't bisect it to the exact commit, then you would need to revert it in a local build, and see if the regression is gone afterwards
Comment 10 Timur 2019-10-18 12:10:03 UTC
I don't have a local build, so we're looking for a volunteer.
Comment 11 Julien Nabet 2019-10-18 15:00:59 UTC
I never understood how to bisect/bibisect something.
However, I can try to revert a specific commit locally but which one precisely.
Comment 12 Timur 2019-10-18 19:20:50 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2019-10-18 20:53:03 UTC
Created attachment 155129 [details]
gdb bt

On pc Debian x86-64 with master sources updated today + gtk3, I got a crash.

I don't reproduce this with gen rendering, perhaps another bug.
Comment 14 Julien Nabet 2019-10-18 20:56:03 UTC
(In reply to Timur from comment #12)
> Thanks Julien. Those in comment 7,when it's convenient for you. I noticed
> you and JBF make your builds so I was free to add you here.

Those are very old, I tried to revert first one but had a lot of conflicts.
Comment 15 Jean-Baptiste Faure 2019-10-20 15:33:38 UTC
I guess the problem comes from the drawing object shapetype_202 that can be seen in the Navigator. There is 3 other drawing objects in this file, but only shapetype_202 can't be removed. It could be interesting to try with the original xlsx file on the current master. I guess the root cause of the problem is a bug in the import from xlsx to ods. Maybe this bug is now fixed.

Best regards. JBF
Comment 16 Timur 2019-10-23 10:23:34 UTC
Another bibisect try gives better results (I verified).
I add Michael and August to CC. Please take a look. 

We are looking at File-Print.. small preview in the print window, no need to really print, but also Print Preview is not the same and so not used.  
First print window was fine, then it was completely empty for this file and finally we have a blank box in print window.
So I was looking for two commits here. 


Commit that spoiled the print window:
bd61690e049a1941a9a555c391165d4cf7288e3b is the first bad commit
commit bd61690e049a1941a9a555c391165d4cf7288e3b
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Dec 8 07:43:16 2011 +0100

    source-hash-1ca547d20882e9b3d3ba9a6c7ee0340a5b7009b0
    
    commit 1ca547d20882e9b3d3ba9a6c7ee0340a5b7009b0
    Author:     Michael Stahl <mstahl@redhat.com>
    AuthorDate: Fri Nov 4 17:50:43 2011 +0100
    Commit:     Michael Stahl <mstahl@redhat.com>
    CommitDate: Sat Nov 5 00:08:33 2011 +0100
    
        reportbuilder: grammar considered neither stylish nor smart-looking

https://gerrit.libreoffice.org/plugins/gitiles/core/+/1ca547d20882e9b3d3ba9a6c7ee0340a5b7009b0^!/

commit	1ca547d20882e9b3d3ba9a6c7ee0340a5b7009b0	[log]
author	Michael Stahl <mstahl@redhat.com>	Fri Nov 04 17:50:43 2011 +0100
committer	Michael Stahl <mstahl@redhat.com>	Sat Nov 05 00:08:33 2011 +0100
tree	39a7baed3245dc8619d54886ed9ea4cdbf9c34ee
parent	974c15923465ebb2cc5c9c99180737298ed69c95 [diff]

reportbuilder: grammar considered neither stylish nor smart-looking


Commit that got blank box in the print window:
761fff35524e6ab47f64d43482d6a9dc06035e86 is the first bad commit
commit 761fff35524e6ab47f64d43482d6a9dc06035e86
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Dec 8 19:10:55 2011 +0100

    source-hash-919abbfe9b1461e4accbdebe4a2475379d2d5731
    
    commit 919abbfe9b1461e4accbdebe4a2475379d2d5731
    Author:     August Sodora <augsod@gmail.com>
    AuthorDate: Sat Nov 26 15:24:38 2011 -0500
    Commit:     August Sodora <augsod@gmail.com>
    CommitDate: Sat Nov 26 18:13:26 2011 -0500
    
        Avoid use of the preprocessor

https://gerrit.libreoffice.org/plugins/gitiles/core/+/919abbfe9b1461e4accbdebe4a2475379d2d5731^!/
commit	919abbfe9b1461e4accbdebe4a2475379d2d5731	[log]
author	August Sodora <augsod@gmail.com>	Sat Nov 26 15:24:38 2011 -0500
committer	August Sodora <augsod@gmail.com>	Sat Nov 26 18:13:26 2011 -0500
tree	44ca7e8aea5fe07594a8e0e27ba26ffee0f62a13
parent	05a29e5a642ca53a21532a3c25ab79db7b40b49c [diff]

Avoid use of the preprocessor
Comment 17 Michael Stahl (CIB) 2019-10-23 11:36:53 UTC
i don't know what bibisect repo this is but i don't believe Bjoerns' repos from 2011 had single-commit resolution, it was more like 30 commits per build?

in any case 1ca547d20882e9b3d3ba9a6c7ee0340a5b7009b0 just changes the description text of reportbuilder extension so can't be the cause; 919abbfe9b1461e4accbdebe4a2475379d2d5731 shouldn't cause any problem either.

-> removing bisected for now
Comment 18 Timur 2019-11-09 13:27:01 UTC
Sorry, Michael, I was just beginning to bibisect, it was 43all and it was wrong conclusion. I remove you from CC.