Bug 115801 - Writer crashes when pressing ESC in formula editor
Summary: Writer crashes when pressing ESC in formula editor
Status: RESOLVED DUPLICATE of bug 115430
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
Depends on:
Blocks:
 
Reported: 2018-02-17 12:42 UTC by Daniel Löb
Modified: 2018-02-17 17:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Löb 2018-02-17 12:42:55 UTC
Description:
When editing a formula in Writer, pressing the ESC key causes writer to crash.

The crash is caught and Writer immediately restarts.

Steps to Reproduce:
1. New Writer document
2. ALT-I, ALT-O, ALT-F to start formula editor
3. Press ESC

Actual Results:  
Writer crashes, then restarts.

Expected Results:
Close formula editor.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.1.1
Build ID: 6.0.1-1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: de-DE (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Dieter Praas 2018-02-17 16:36:04 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL

But not with

Version: 5.4.4.2 (x64)
Build-ID: 2524958677847fb3bb44820e40380acbe820f960
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Maxim Monastirsky 2018-02-17 17:10:31 UTC

*** This bug has been marked as a duplicate of bug 115430 ***