Bug Hunting Session
Bug 115813 - Position shifted while moving the handle of OOXML Callout shape
Summary: Position shifted while moving the handle of OOXML Callout shape
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Regina Henschel
URL:
Whiteboard: target:6.3.0
Keywords: filter:docx
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2018-02-17 22:13 UTC by Aron Budea
Modified: 2019-08-13 22:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Collection of shapes for testing (74.37 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-04-08 17:14 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-02-17 22:13:48 UTC
- Open attachment 139854 [details] from bug 115671, a DOCX created in MS Office with a single callout shape.
- Grab handle of the callout shape.

=> The handle is shown at a shifted position compared to where the cursor is.

Reproduced using LO 6.1.0.1 & 5.3.0.3 / Windows 7.
In 5.2.0.4 it behaved worse, the handle immediately shifted out of view when the user grabbed the handle, so something changed since then, but the behavior still isn't correct.
Comment 1 Imai 2018-02-19 06:07:48 UTC
Issue is reproduced.

OS X EL Capitan
Ver:10.11.3

version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS:Mac OS X 10.11.3; UI render: default; 
local: ja-JP (ja.UTF-8); Calc: group
Comment 2 QA Administrators 2019-03-08 03:40:13 UTC Comment hidden (obsolete)
Comment 3 Regina Henschel 2019-04-07 18:06:54 UTC
The bug still exists in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 287df6cf083a8ebeea8d64108a9e6d74cd834319
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Regina Henschel 2019-04-08 17:14:19 UTC
Created attachment 150616 [details]
Collection of shapes for testing

The problem seems to be serious. Besides mismatch between handle point and cursor position, I see movement in opposite direction than cursor movement and I see freeze of handle.

The attached file contains all shapes from current PowerPoint. I have set those shapes to gray, which do not have handles. Those shapes, which seem to be OK, are green. Those shapes, which have at least one handle acting wrong, are orange.
Comment 5 Regina Henschel 2019-04-12 23:20:46 UTC
I have started to look at this bug. First ideas can be seen in https://gerrit.libreoffice.org/#/c/70689/1

Discussions about the patch please on dev mailing list.
Comment 6 Regina Henschel 2019-04-24 23:03:37 UTC
Now in https://gerrit.libreoffice.org/#/c/71258/
Comment 7 Commit Notification 2019-04-30 15:11:53 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/89ce0ef3744572127a75fbe82c2fc194ce63b702%5E%21

tdf#115813 Get correct adjust value from XY handle of ooxml-shape

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Regina Henschel 2019-05-05 15:59:08 UTC
fixed in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 15c39bb2e75df40c30bcbf789d815376dd2e31ce
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-02_22:43:22
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

The patch fixes only the XY-handles. I have written the follow-up bug 125126 for polar handles.
Comment 9 Aron Budea 2019-05-07 21:30:18 UTC
Verified, thank for the fix, Regina!

Version: 6.3.0.0.alpha0+ (x64)
Build ID: d6e8e41c22023bc15cc4c9659b33c1cc3d6edb75
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-06_01:12:47
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 10 Commit Notification 2019-05-17 19:17:25 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4ca556d041b3e27c4aeebf7434814eb8a4350203%5E%21

tdf#115813 unit test for handle position of OOXML shapes

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 gbinfo 2019-08-13 22:13:32 UTC
May I bring bug #65441 to your attention as it seems to be related to this?