Bug Hunting Session
Bug 115842 - All menus (top and context) have zero height, only an up and down arrow
Summary: All menus (top and context) have zero height, only an up and down arrow
Status: RESOLVED DUPLICATE of bug 111987
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2018-02-19 08:55 UTC by Marnix
Modified: 2018-03-29 06:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Menu example (79.78 KB, image/png)
2018-02-19 08:57 UTC, Marnix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marnix 2018-02-19 08:55:39 UTC
Description:
All menus (top and context) have zero height, only an up and down arrow.
It seems to occur only while using the Quickstarter (have it loaded during system boot).
Libre is opened by double clicking a file.

Setup is dual screen (extended).
I disabled the quickstarter on all of our systems due to this bug (and reenabled it during 6.0.1.1 install to retry).
A working hot fix when the bug occurs is closing the quickstarter and replugging a monitor's signal cable (triggering a screen resolution reset).
OpenGL is disabled on the system I tested with this morning.

Stated earliest version isn't exact: I don't know the exact version; I've been having this issue over 6 months now (and started to use the work around: disable quickstarter).

Other reports (not mine):
https://ask.libreoffice.org/en/question/142590/no-menu-display-no-context-menus/


Steps to Reproduce:
1.boot with having the quickstarter enabled on a multi screen Windows machine 
2.open a document (docx, xls)
3.try to access a menu

Actual Results:  
The shown menu has only an up and a down arrow

Expected Results:
show menu items


Reproducible: Sometimes


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Marnix 2018-02-19 08:57:45 UTC
Created attachment 139985 [details]
Menu example
Comment 2 V Stuart Foote 2018-02-19 16:05:59 UTC
What build of Windows? What Graphics chipset(s) and driver(s)? What resolution for the two monitors of the multihead? What video cable format (VGA, DVI, DP, HDMI)?

Also, additional changes at 6.0.1 and recent master builds--have you checked those as 5.4 is not likely to be corrected.
Comment 3 Marnix 2018-02-26 16:03:41 UTC
Most recent occurance:

Libre 6.0.1.1
Win 10 Home (10.0.16299)
Intel HD Graphics 400 (driver version: 20.19.15.4835)
1366x768, twice: one via VGA and one via HDMI

After we had the bug frequently on 5.x we switched of the quickstarter to enable my colleagues to keep working (as Libre is installed on the Windows workstations of my colleagues). After upgrading from 5.x to 6.0.1.1 I reenabled the quick starter on 1 system to check whether the bug resurfaced. The 2nd or 3rd day the bug did resurface (and I disabled the quick starter again).
I don't know if Libre was used in the 1 or 2 days between enabling the quickstarter and the bug showing up again.

The bug also manifested on:
Libre 5.?
Win10 Pro (10.0.16299)
Intel HD Graphics 630 (driver version 21.20.16.4550)
1920x1080 (twice) using HDMI and VGA
(haven't had the quickstarter active on this machine since installing 6.0.1.1)

Both systems (incl Libre) are in Dutch.
Comment 4 V Stuart Foote 2018-02-26 18:15:16 UTC
OK, thanks => Unconfirmed

Use of the Quickstarter "anti-feature" aside, is OpenGL enabled or not for these Intel GPU multi-head systems? 

Also, would note that the listed drivers are a bit dated. And always necessary to test OpenGL behavior with the last couple of driver sets. Plese update and retest. 

Latest is Intel 15.65 (for Win10) is at 4944 (2018-02-16)[1] while Intel 15.36 (for Win8.1/7) is at 4889 (2018-01-16) [2]. Intel explains the difference between their notation and Microsoft's notation in [3].


=-ref-=
[1] https://downloadcenter.intel.com/download/27484/Graphics-Intel-Graphics-Driver-for-Windows-15-65-?product=80939

[2] https://downloadcenter.intel.com/product/80939/Graphics-Drivers

[3] https://www.intel.com/content/www/us/en/support/articles/000005654/graphics-drivers.html
Comment 5 Marnix 2018-02-27 09:12:37 UTC
What do you mean with "anti-feature"?

For the Intel HD Graphics 400 (OpenGL is disabled) there seems to be no updated driver.
Because of this, I left the Quickstarter disabled for now (as I made no change to the system).

I updated the drivers for the HD Graphics 630 through the Dell site to 23.20.16.4849
* downloadpage: http://www.dell.com/support/home/nl/nl/nldhs1/drivers/driversdetails?driverId=18HK3
* seems to be https://software.intel.com/en-us/blogs/2017/11/06/new-1560014849-intel-graphics-driver-for-windows-10-64-bit-6th-7th-8th-generation

Your newer drivers couldn't be installed on this system: I had to use the site from the manufacturer.

I reenabled the Quickstarter.
OpenGL is enabled for this system; the OpenGL blacklist is unchecked. (left these as they were; it's not deliberately set this way)

I'll update here if the bug resurfaces.
Comment 6 Marnix 2018-03-01 08:07:43 UTC
The bug still exists: the colleague using the Win10 Pro with the HD Graphics 630 reported the issue resurfaced the morning after reenabling the Quickstarter.
She reports it occurs when opening an Excel-file using Calc; I guess it will also occur using writer, but her work involves mainly spreadsheets.

She told me that when she ran into the bug while the Quickstarter was enabled, she kills the Libre process using task manager. When reopening the file, the menus would be normal.
This workaround, together with my own workaround (replugging a monitor cable) made me think: could it be that the Quickstarter fails to detect the available screen space? That would explain the bug (zero height menus, because the renderer thinks there is no space for the menu to load) and the used workarounds (which both force Libre to remeasure the available screen space).
Comment 7 Buovjaga 2018-03-09 17:45:45 UTC
Like Stuart said, Quickstarter is a bad feature and there are plans to remove it in a future release: https://wiki.documentfoundation.org/ReleaseNotes/6.0#General_3
Comment 8 Aron Budea 2018-03-12 04:52:37 UTC
This bug came up before, but the involvement of Quickstarter seems to be a valuable hint, thanks for the details!

*** This bug has been marked as a duplicate of bug 111987 ***
Comment 9 Aron Budea 2018-03-29 03:51:02 UTC
(In reply to Marnix from comment #6)
> The bug still exists: the colleague using the Win10 Pro with the HD Graphics
> 630 reported the issue resurfaced the morning after reenabling the
> Quickstarter.

I tried out what happens with Quickstarter enabled, but still hasn't encountered this bug. I'm curious about what kind of environment could be needed for it.
Comment 10 Marnix 2018-03-29 06:31:34 UTC
I think my colleagues reported the bug never sooner than the first day after (re)enabling the Quickstarter.
I couldn't reproduce either by enabling the Quickstarter and rebooting the system right after.