Bug 115853 - Custom properties deleted
Summary: Custom properties deleted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.4.1 rc
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.1.0 target:6.0.4 target:5.4.7
Keywords:
: 116260 (view as bug list)
Depends on:
Blocks: File-Properties
  Show dependency treegraph
 
Reported: 2018-02-19 13:44 UTC by Ysabeau
Modified: 2018-04-11 21:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ysabeau 2018-02-19 13:44:54 UTC
Description:
Enter and fill a new custom property. When you add another it is deleted.

Steps to Reproduce:
1. Create a file
2. Open the properties, go to Custom Properties
3. Add a property, fill the fields (text)
4. Add another property, the content of the first you did is deleted

Actual Results:  
The content of the custom properties are deleted.

Expected Results:
LibreOffice should keep them as it was the case before.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
There is a workaround: add several custom properties, more than the number you need and then fill them. Click on Ok to close the box.

The empty properties will be deleted, the file only keeps the filled ones. But it is only a workaround.

It "works" with personal properties or the one you can choose in the list. Note that, concerning the content of the custom properties, LibreOffice keeps the dates when they are formatted as dates, but not the name of the property itself.

I saw that with 5.4 (don't remember exactly what number) and now in the 6 release.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Julien Nabet 2018-02-19 21:05:32 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Here's a file to start investigation:
sfx2/source/dialog/dinfdlg.cxx
Comment 2 Julien Nabet 2018-02-20 22:52:03 UTC
I submitted for review this patch on gerrit:
https://gerrit.libreoffice.org/#/c/50070/
Comment 3 Julien Nabet 2018-03-07 10:12:34 UTC
*** Bug 116260 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2018-03-12 22:47:12 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a1a60f79c6ffccfd49034a6251031e1f9a0c63a0

tdf#115853: save current custom property when adding line

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2018-03-18 19:50:42 UTC
Don't hesitate to reopen this tracker if you still reproduce this with a recent daily build from master.
Comment 6 Jean-Baptiste Faure 2018-03-31 16:38:45 UTC
Thank you Julien for this fix. It works for me on the current master.
Do you plan to backport it to 6.0 and 5.4 ?

Best regards. JBF
Comment 7 Commit Notification 2018-04-03 07:44:46 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d3313c832862b545cf6ec35c2b6c5fc08d8213c&h=libreoffice-6-0

tdf#115853: save current custom property when adding line

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-04-11 21:45:30 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c522b4017915b3a12203ac39f48a75ae6f4a5bc0&h=libreoffice-5-4

tdf#115853: save current custom property when adding line

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.