Download it now!
Bug 115870 - Libre office loops crashing on opening documents
Summary: Libre office loops crashing on opening documents
Status: RESOLVED DUPLICATE of bug 112990
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-20 06:11 UTC by jmgigandet
Modified: 2018-02-20 10:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmgigandet 2018-02-20 06:11:34 UTC
On OSX, opening a valid document with LibreOffice version 6.0.0 or 6.0.1 crashes.
The app indicates it will repair the doc on restart.
It restarts, repairs the doc, and crashes again.
You can try x times, and suddenly the doc opens.
But if you save and try to open again, the crash comes back.
Tested on several Macs.
No problem when opening the same docs, with LO 5.4 or Microsoft Office.
Comment 1 Imai 2018-02-20 08:56:45 UTC
Issue is reproduced.
Open document no problem for me.

----
OS X EL Capitan
Ver:10.11.3

version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS:Mac OS X 10.11.3; UI render: default; 
local: ja-JP (ja.UTF-8); Calc: group
Comment 2 Xisco Faulí 2018-02-20 10:50:00 UTC
Hello,
This is problably because OpenGL is enabled. You can disable it from Tools ▸ Options ▸ LibreOffice ▸ View and uncheck Use OpenGL for all rendering.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 112990 ***