Download it now!
Bug 115889 - LibreOffice Calc copied also filtered rows into clipboard!
Summary: LibreOffice Calc copied also filtered rows into clipboard!
Status: RESOLVED DUPLICATE of bug 36466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-20 19:35 UTC by StenW
Modified: 2018-04-02 09:08 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description StenW 2018-02-20 19:35:21 UTC
Description:
To me this is a big bug in the tool. Whenever i copy some VISIBLE rows to clipboard i want those rows to be on the clipboard.
Unfortunately that is not the case as with a range of filtered rows selected, the clipboard receives ALL rows between the first and last selected.
Please fix ASAP to avoid risk of revealing of unintended information!
Also, it would be great if the clipboard format produced by this tool would also always become normal text clipboard format on Windows virtual machine under KVM.

Steps to Reproduce:
1.Autofilter some rows by a column
2.copy all rows visible
3.ctrl-c
4.start qedit or Notepad@windows  and ctrl-v (and be surprised)

Actual Results:  
All rows included

Expected Results:
Only selected VISIBLE rows expected


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Timur 2018-02-21 12:05:13 UTC
Please clarify with regard to https://help.libreoffice.org/Calc/Only_Copy_Visible_Cells.
If you're referring to hidden cells then this is a duplicate of Bug 36466.
If you're referring to cells filtered by AutoFilter then I don't repro.
Comment 2 Timur 2018-02-21 12:23:58 UTC
Please provide test document and exact steps.
Comment 3 Timur 2018-04-02 09:08:43 UTC
Since no response, I'll mark as a dupe of 36466. 
If not correct, please set to Unconfirmed.

*** This bug has been marked as a duplicate of bug 36466 ***