Bug Hunting Session
Bug 115931 - ScFiltersTest::testOrcusODSStyleInterface fails with liborcus 0.13.3
Summary: ScFiltersTest::testOrcusODSStyleInterface fails with liborcus 0.13.3
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 08:08 UTC by Olivier Tilloy
Modified: 2018-02-22 13:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Tilloy 2018-02-22 08:08:20 UTC
Description:
(originally reported against the ubuntu package: https://launchpad.net/bugs/1750982)

subsequent_filters-test.cxx:2398:Assertion
Test name: ScFiltersTest::testOrcusODSStyleInterface
equality assertion failed
- Expected: Color: R:254 G:255 B: 204
- Actual : Color: R:255 G:255 B: 255

This is most likely caused by that upstream change: https://gitlab.com/orcus/orcus/commit/f821995022df8dd1e580dd22cf131584b2b1ac4f

Steps to Reproduce:
Build libreoffice 6.0 with an external liborcus (version 0.13.3) and run the unit tests.

Actual Results:  
ScFiltersTest::testOrcusODSStyleInterface fails.

Expected Results:
All unit tests pass.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/65.0.3325.73 Chrome/65.0.3325.73 Safari/537.36
Comment 1 Olivier Tilloy 2018-02-22 08:21:12 UTC
https://github.com/LibreOffice/core/commit/20945a9a4de6684010fd5b3603595e6da543807d mentions that liborcus 0.13.3 is expected to have the correct ODF styles, so I assume the unit tests will have to be updated.
Comment 2 Olivier Tilloy 2018-02-22 08:40:19 UTC
Tentative patch (untested, might not be complete):

--- a/sc/source/filter/orcus/interface.cxx
+++ b/sc/source/filter/orcus/interface.cxx
@@ -839,7 +839,7 @@ void ScOrcusStyles::fill::applyToItemSet
         return;
     }
 
-    rSet.Put(SvxBrushItem(maBgColor, ATTR_BACKGROUND));
+    rSet.Put(SvxBrushItem(maFgColor, ATTR_BACKGROUND));
 }
Comment 3 Xisco Faulí 2018-02-22 12:26:19 UTC
Hello Olivier,
Since this is an issue in the building system and not in the software itself, would you mind sending an email to the dev mailing list instead adding Kohei as Cc? -> https://wiki.documentfoundation.org/Development/Mailing_List

Setting as RESOLVED MOVED
Sorry for the inconveniences.
Comment 4 Olivier Tilloy 2018-02-22 12:53:20 UTC
I can do that for sure, but as soon as the dependency on liborcus is bumped to 0.13.3 it will become an issue in libreoffice, requiring changes in the codebase.

So I'm not sure I agree it's not an issue in the software itself. It's just that it hasn't manifested itself yet, but it eventually will.
Comment 5 Olivier Tilloy 2018-02-22 13:03:23 UTC
Moved conversation to the mailing list: https://lists.freedesktop.org/archives/libreoffice/2018-February/079531.html