Bug 115937 - FILEOPEN: crash when opening this .odp file
Summary: FILEOPEN: crash when opening this .odp file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Windows (All)
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.1
Keywords: bibisected, regression, wantBacktrace
Depends on:
Blocks: File-Opening
  Show dependency treegraph
 
Reported: 2018-02-22 17:05 UTC by Frederic Parrenin
Modified: 2018-08-25 17:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["sd::SimpleReferenceComponent::release()"]


Attachments
.odp file which crashes Impress (1.57 MB, application/vnd.oasis.opendocument.presentation)
2018-02-22 18:02 UTC, Frederic Parrenin
Details
read wi MS Office 2016 and save as odp (69.23 KB, application/vnd.oasis.opendocument.presentation)
2018-06-22 17:16 UTC, paulystefan
Details
backtrace (6.66 KB, text/plain)
2018-08-21 13:59 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2018-02-22 17:05:11 UTC
On my windows 10 machine, LO 6.0.1 crashes when opening the following .odp file:
https://mycore.core-cloud.net/index.php/s/rvn16MP5snj3Iz0
I don't have this problem on my debian linux machine using the same LO version.
Comment 1 Frederic Parrenin 2018-02-22 18:02:41 UTC
Created attachment 140061 [details]
.odp file which crashes Impress

I attach a simpler example which crashes LO Impress.
Comment 2 Xisco Faulí 2018-02-22 18:38:27 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: ddbb78caa78085673b07dbea6f53288ec6237764
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but I can in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

Version: 6.1.0.0.alpha0+
Build ID: 8b1a83bffe35ae0e71735569512c1586bcb37b25
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-23_08:54:58
Locale: es-ES (es_ES); Calc: group threaded

but not in

Versión: 4.4.0.3
Id. de compilación: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Configuración regional: es_ES

although it's quite slow in 4.4.0.3
Comment 3 Aron Budea 2018-02-24 02:26:33 UTC
Bibisected to the following range using repo bibisect-win32-5.0 (single commit in the repo, can't be bibisected further):
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=b72c6feba87bd8707f39902a3066ba476188cb1d..ce82146a6be87b239a0bde0b59fddf8865290b99
Comment 4 Michael Meeks 2018-03-06 09:32:23 UTC
Hi Aron - might be good to bisect the fix out of 6.1.0.0 =) if it started working.
Comment 5 Aron Budea 2018-03-08 03:37:42 UTC
Hi Michael, unfortunately it hasn't started working in 6.1, but it seems to be Windows-only. I could repro it with a master build from a couple of days ago (60bfb1526849283ce2491346ed2aa51c465abfe6).
Comment 6 paulystefan 2018-06-22 17:16:37 UTC
Created attachment 143050 [details]
read wi MS Office 2016 and save as odp

radical reduction of size in MS Office

but i shows a page in powerpoint.

and then it goes with LO 5.4.7.2-64 in Win10
Comment 7 Caolán McNamara 2018-08-21 13:59:10 UTC
Created attachment 144347 [details]
backtrace

backtrace of an exception I suspect is relevant
Comment 8 Caolán McNamara 2018-08-21 14:53:50 UTC
I think I can see the problem
Comment 9 Caolán McNamara 2018-08-21 20:14:38 UTC
Fixed this with https://cgit.freedesktop.org/libreoffice/core/commit/?id=05e14fdeeebe1b5bb35c847ceafc80fe9bdef16a in master, 6-0 and 6-1 backports in gerrit. Used the wrong id, but fixed it in the 6-1 version
Comment 10 Commit Notification 2018-08-21 20:15:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1410cefdb5f6048bb62eb7d141d4d2cfc0018cd7&h=libreoffice-6-1

Resolves: tdf#115937 virtual device leak

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2018-08-25 17:07:32 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: af579ed7d1482df5cfa7e12e8af2603917d40602
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: threaded

@Caolán McNamara, Thanks for fixing this!!