Bug Hunting Session
Bug 115947 - FILESAVE: COPY: Inability to copy-to-clipboard the filename from the file-save dialogue box
Summary: FILESAVE: COPY: Inability to copy-to-clipboard the filename from the file-sav...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 21:40 UTC by tagishsimon
Modified: 2018-02-23 10:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
the file save dialogue box (76.14 KB, image/png)
2018-02-23 08:50 UTC, tagishsimon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagishsimon 2018-02-22 21:40:23 UTC
Description:
We should be able to copy the filename of a Calc file to the clipboard, by, for instance, File, Save As (to bring up the FileSave dialogue box) and then CTRL-A CTRL-C in the Save As field.

Although CTRL-A works fine, CTRL-C does not copy the selected text to the clipboard.

(The usecase for this is to capture a filename so as to use it elsewhere ... something I often have cause to do)

Steps to Reproduce:
1. Create Calc file
2. Save calc file
3. File, Save As
4. Select some or all of the filename in the Save As field
5. CTRL-C

Actual Results:  
Selected content is NOT copied to the clipboard

Expected Results:
Selected content IS copied to the clipboard


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Alex Thurgood 2018-02-23 08:11:45 UTC
No repro with 

Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

1) opened a CSV file
2) Menu Save as... ODS
3) In the Finder window, Cmd-A then Cmd-C to copy the file name
4) Cmd-V to paste into TextWrangler text document.


Everything seems to work here for me.
Which application are you attempting to paste the filename into ?
Comment 2 tagishsimon 2018-02-23 08:49:01 UTC
I'm attempting to paste into the LibreOffice Calc file. It fails.

However seeking to paste it into TextEdit succeeds.

So, this is my new test.

1. Create Calc file
2. Save Calc file as junk.ods
3. Write something in a cell - e.g. Foo
4. Focus on the cell, CTRL-C
5. Move somewhere else on the sheet, CTRL-V - all good, the copy & paste worked
6. Whilst still in the junk.ods file, File, Save As
7. Cursor focus on the Save As field in the file save dialogue box
8. CTRL-A, CTRL-C
9. Cancel out of the file save dialogue box
10. Focus on a cell
11. CTRL-V into cell - FAIL. I paste the value I collected in Step 4
12. Command-Tab to TextEdit
13. CTRL-V - Success - the filename is pasted
14. Command-Tab back into the LibreOffice spreadsheet
15. CTRL-V - Success - the filename is pasted

hth
Comment 3 tagishsimon 2018-02-23 08:50:43 UTC
Created attachment 140082 [details]
the file save dialogue box

This is the thing I mean when I use the phrase 'file save dialogue box'
Comment 4 tagishsimon 2018-02-23 08:51:55 UTC
And I note you say "3) In the Finder window, Cmd-A then Cmd-C to copy the file name" ... for the avoidance of uncertainty, I've attached a screengrab of what I'm meaning by the file save dialogue box ... hopefully we're talking about the same thing.
Comment 5 Alex Thurgood 2018-02-23 09:54:24 UTC
We are talking about the same dialog.
However I still can't reproduce the problem.

Steps 10 and 11 as described in comment 2 work for me, the filename copied from the Save as dialogue is pasted into a cell of my choosing. It doesn't matter whether I just select a cell or double-click to enter the cell, both work and the filename is pasted into the cell.
Comment 6 Alex Thurgood 2018-02-23 09:56:02 UTC
Are you still using 6.0.0.3 ?

If so, then please try with a current 6.0.1.1
Comment 7 tagishsimon 2018-02-23 10:32:31 UTC
In 6.0.1.1 ... it works as expected. I've marked this as Resolved / Notabug. thx for your input, Alex.