Bug 115968 - CMIS: various protocol handling problems & incompatibilities
Summary: CMIS: various protocol handling problems & incompatibilities
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2018-02-23 14:00 UTC by Thorsten Behrens (allotropia)
Modified: 2021-06-27 04:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Behrens (allotropia) 2018-02-23 14:00:54 UTC
Running LibreOffice against standard-conformant CMIS servers like Apache Chemistry exposes all kinds of protocol errors - seems libcmis puts way too many constraints on server responses.

See here for test code:
https://chemistry.apache.org/java/developing/
Comment 1 Commit Notification 2018-02-24 12:58:01 UTC
Andreas Brandner committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=974ef69c73a4e62b7513effa5c5b8d46ec0a1c80

tdf#115968: make libcmis work better with CIB doxima

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Xisco Faulí 2018-03-27 09:11:09 UTC
A polite ping to Andreas Brandner & Thorsten Behrens: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 3 Thorsten Behrens (allotropia) 2018-03-27 10:02:00 UTC
Ah right, updating status.
Comment 4 Xisco Faulí 2018-06-26 09:42:28 UTC
Dear Andreas Brandner (CIB),
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 5 QA Administrators 2019-06-27 02:52:58 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2021-06-27 04:19:32 UTC
Dear Thorsten Behrens (CIB),

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug