Bug 115998 - Delete relationship in base. Crash in: google_breakpad::ExceptionHandler::HandlePureVirtualCall()
Summary: Delete relationship in base. Crash in: google_breakpad::ExceptionHandler::Han...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-02-24 23:13 UTC by twisterddfsl83823
Modified: 2018-03-15 15:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["google_breakpad::ExceptionHandler::HandlePureVirtualCall()","vcl::Window::dispose()"]


Attachments
Test case. (17.56 KB, application/vnd.sun.xml.base)
2018-02-25 00:39 UTC, twisterddfsl83823
Details
Test case 2. - Previous one appeared to be corrupted. (17.56 KB, application/vnd.sun.xml.base)
2018-02-25 00:42 UTC, twisterddfsl83823
Details
bt with debug symbols (6.74 KB, text/plain)
2018-02-25 16:55 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description twisterddfsl83823 2018-02-24 23:13:16 UTC
This bug was filed from the crash reporting server and is br-1c9f2e97-0ddc-4fbb-bf5a-4255b1583fa7.
=========================================

Deleted a relationship or a table on the relationship view will lock up base.
Comment 1 twisterddfsl83823 2018-02-25 00:39:39 UTC
Created attachment 140122 [details]
Test case.

If you go to relationships, select a table that has a relationship and hit delete, the program will lock up.
Comment 2 twisterddfsl83823 2018-02-25 00:42:02 UTC
Created attachment 140123 [details]
Test case 2. - Previous one appeared to be corrupted.

Select a table in releationship view, hit delete, experience lock-up.
Comment 3 twisterddfsl83823 2018-02-25 00:43:54 UTC
I tried uploading a test case twice.  Downloading it and opening it with libreoffice results in error messages.
Comment 4 Xisco Faulí 2018-02-25 01:57:30 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: ddbb78caa78085673b07dbea6f53288ec6237764
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.13; Render: default; 


but not in

Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311
Locale: ca_ES
Comment 6 Julien Nabet 2018-02-25 10:05:12 UTC
On pc Debian x86-64 with master sources updated yesterday, the first time I tested, I had a crash then I tested other times with gdb to retrieve a bt, no crash, no lock.
Finally, I retried without gdb and couldn't reproduce the crash.
Race condition?
Comment 7 twisterddfsl83823 2018-02-25 14:18:51 UTC
All I know is that I've been getting a good number of lockups while I was creating and modifying a base file.  The problem is allot of them either I'm not sure what triggered it... or don't trigger always.

Delete a relationship in my one database will trigger a lockup 90% of the time... but in the new file... I couldn't cause that to trigger it.
But selecting and deleting a table on the relationship view would trigger it.

There were some rare lockups that I think are triggered by saving a modified form... but they occur so rarely, I haven't been able to pin them down.  ( I had it occur only 4 times yesterday when I was working with base all day)

That's all the info I know.

If anyone has suggestions on what I can do to collect more data to help... I'm all ears.  I'm new to reporting bugs here.
Comment 8 Julien Nabet 2018-02-25 16:55:40 UTC
Created attachment 140136 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated yesterday, I could reproduce the crash by selecting a table in the relationships then deleting by type "suppr" and confirming.
I attached bt with symbols
Comment 9 Commit Notification 2018-03-05 07:39:13 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46b32a022ee3679721e410e470c57b6a0b91ecb0

tdf#115998 base: crash on delete relationship

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-03-05 16:23:14 UTC
verified in

Version: 6.1.0.0.alpha0+
Build ID: 2affed9bfd72628549df3049ed9f6e6a30fdb5b8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thanks Noel
Comment 11 Commit Notification 2018-03-15 15:30:42 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63bd3beb23e1d8975cea209501c63d4c84396e26&h=libreoffice-6-0

tdf#115998 base: crash on delete relationship

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.