Download it now!
Bug 116031 - Calc grid lines don't print when the spreadsheet have a PNG image.
Summary: Calc grid lines don't print when the spreadsheet have a PNG image.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Border Print
  Show dependency treegraph
 
Reported: 2018-02-26 14:55 UTC by Everton Dreher
Modified: 2020-09-04 07:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Issue example. (5.09 MB, image/jpeg)
2018-02-26 16:34 UTC, Everton Dreher
Details
ODS file (39.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-02-27 13:25 UTC, Everton Dreher
Details
PDF files - Microsoft Print to PDF (156.85 KB, image/jpeg)
2018-02-27 18:52 UTC, Everton Dreher
Details
printed pdf file (595.53 KB, application/pdf)
2018-02-28 13:55 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Everton Dreher 2018-02-26 14:55:40 UTC
Description:
When a PNG image is insert on a spreadsheet, some grid lines are not printed.
If the image is converted to JPG, the grid lines print normally.

I tested this in different PCs and printers, in 5.4.5.1 and 6.0.1 releases.

Steps to Reproduce:
1. Open a spreadsheet file on LibreOffice Calc;
2. Select some cells and insert borders
3. Insert a PNG image in the spreadsheet;
4. Print the file;

Actual Results:  
Some bordered cells don't apears on the printed file.

Expected Results:
All bordered cells appear in the printed file.


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.170 Safari/537.36 Vivaldi/1.95.1077.50
Comment 1 Everton Dreher 2018-02-26 16:34:12 UTC
Created attachment 140159 [details]
Issue example.
Comment 2 Xisco Faulí 2018-02-26 16:41:15 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-02-26 17:17:54 UTC Comment hidden (obsolete)
Comment 4 Everton Dreher 2018-02-26 17:53:30 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2018-02-27 09:01:39 UTC
(In reply to Everton Dreher from comment #4)
> I uploaded a photo comparing two printed files: one with the image in PNG
> and another with JPG

Hi Everton Dreher,
Please, upload the source .ods file where this issue is reproduced...
Comment 6 Everton Dreher 2018-02-27 13:25:15 UTC
Created attachment 140175 [details]
ODS file
Comment 7 Xisco Faulí 2018-02-27 17:34:48 UTC Comment hidden (obsolete)
Comment 8 Everton Dreher 2018-02-27 18:51:55 UTC
Hi Xisco,
If I export to PDF or go to print view, the issue is not reproduced. But if i try to print, and select "Microsoft Print to PDF" option, the lines turn weak when the spreadsheet have a PNG image.
I attached an image showing this.
Comment 9 Everton Dreher 2018-02-27 18:52:39 UTC
Created attachment 140189 [details]
PDF files - Microsoft Print to PDF
Comment 10 Kevin Suo 2018-02-28 13:55:51 UTC
Created attachment 140220 [details]
printed pdf file

I reproduce this in:

Version: 6.0.1.1 (x64)
Build ID:60bfb1526849283ce2491346ed2aa51c465abfe6
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
区域语言:zh-CN (zh_CN); Calc: group

Attached is the printed pdf using Microsoft Print to PDF virtual printer.
Exporting directly to PDF works fine.
Comment 11 Xisco Faulí 2018-03-01 10:16:03 UTC
I can't reproduce it with cups-pdf and 

Version: 6.1.0.0.alpha0+
Build ID: e2cb154195fdc2ffccdb6f5e87cae8b29640b3eb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Win only ?
Comment 12 Xisco Faulí 2018-03-01 11:17:21 UTC
(In reply to Kevin Suo from comment #10)
> Created attachment 140220 [details]
> printed pdf file
> 
> I reproduce this in:
> 
> Version: 6.0.1.1 (x64)
> Build ID:60bfb1526849283ce2491346ed2aa51c465abfe6
> CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
> 区域语言:zh-CN (zh_CN); Calc: group
> 
> Attached is the printed pdf using Microsoft Print to PDF virtual printer.
> Exporting directly to PDF works fine.

I've just found something interesting with your file...

The grids are wrongly displayed in Firefox, but not in Chrome, xreader or Adobe Reader
Comment 13 Xisco Faulí 2018-03-01 11:20:17 UTC
@Everton, Could you please try with an older versions of LibreOffice ( ie: LibreOffice 4.4 or 3.3) to see if it's a regressions? -> https://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 14 Everton Dreher 2018-03-01 14:58:32 UTC
Hi Xisco,
I've try in 4.4.7.2 version, and the issue has reproduced too.
Comment 15 Xisco Faulí 2018-03-01 15:03:38 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2019-03-02 03:51:12 UTC Comment hidden (obsolete)
Comment 17 Timur 2020-09-04 07:46:28 UTC
I don't understand this bug and set back Needinfo. 
What is the difference between Expected and Experienced? Comparison screenshot please or mark on result what's wrong. 
IS this related to Format-Page-Sheet-Print-Grid?
Comment 18 Timur 2020-09-04 07:51:48 UTC
Oh, seema the line on the right , in the first row with image. 
Looks long time resolved, at least in LO 6.2. I set WFM.