Bug 116071 - FILESAVE: .doc style is lost after saving file as .odt
Summary: FILESAVE: .doc style is lost after saving file as .odt
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.4....
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC-Paragraph DrawingLayer-FillStyles-regressions
  Show dependency treegraph
 
Reported: 2018-02-27 20:51 UTC by howil
Modified: 2019-11-19 18:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
original .doc where some are-fill style is used for Heading 1 (23.50 KB, application/msword)
2018-02-27 20:52 UTC, howil
Details
After saving the file as .odt the area-fill style is gone (set to None) for Heading 1 (14.15 KB, application/vnd.oasis.opendocument.text)
2018-02-27 20:53 UTC, howil
Details
tdf116071_paraStyleBackground.odt: area color kept, but not changeable via UI in .doc format (11.70 KB, application/vnd.oasis.opendocument.text)
2018-11-28 08:44 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description howil 2018-02-27 20:51:31 UTC
Description:
I have to use a .doc file where some style for a heading is used. In particular, a background area-fill is set for 'Heading 1'. 
If I save this .doc as .odt and reopen the file the 'Area'-fill is set to 'None'.
As long as I use the .doc nothing changes on reopen. But if I look into the style I see already 'None' set for the 'Area'-fill tab. So I think that LO-Writer does show the imported style correctly but does not set the dialogues for the styles corretly. When saving the document as .odt all some information about the style is lost.

Steps to Reproduce:
1. Open the attached .doc file 
2. Check the style of 'Heading 1': Area is set to 'None' even if a color is used as background fill
3. Save file as .odt
4. Close LO and reopen the .odt file; The Fill color of 'Heading 1' is no more visible!! 
5. Check the style of 'Heading 1': Area is still set to 'None'.

Actual Results:  
After saving the .doc as .odt some style information like 'Area'-fill is gone.

Expected Results:
The saved .odt should look like the .doc (with area-fill in headings)


Reproducible: Always


User Profile Reset: No



Additional Info:
The area fill is visible as long as you use the .doc even if in the style-dialogue the 'Area' is set to 'None'. Maybe only the dialogue values are not set correctly in the first place when opening in with the .doc.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 howil 2018-02-27 20:52:40 UTC
Created attachment 140193 [details]
original .doc where some are-fill style is used for Heading 1
Comment 2 howil 2018-02-27 20:53:40 UTC
Created attachment 140194 [details]
After saving the file as .odt the area-fill style is gone (set to None) for Heading 1
Comment 3 Buovjaga 2018-03-08 20:03:55 UTC
Yep, it's definitely weird: the style shows RGB values in the Organizer tab for the blue and also shows the blue as preview in Font & Font effects.

In 3.3, the background tab shows the blue, but "No fill" as the name.
3.6 shows the blue as well, but empty name.
Both older versions do not lose the colour after saving as odt.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: b8fe96f1da2c42c04a8094ca8c57d49763b7bded
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 8th 2018

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Xisco Faulí 2018-03-14 10:18:19 UTC
Regression introduced by:

author	Armin Le Grand <alg@apache.org>	2014-04-17 16:44:58 +0000
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-04-25 13:08:06 +0200
commit	4a0b5e569d070c286daefb0fdfe45c0dd15d241c (patch)
tree	67f0a293e7174cb871c49a4e5078920d7b8321b8
parent	474fe287c4c97427a4b48d0c0d17f3231290150a (diff)
i#124638 support for DrawingLayre FillStyle for GraphicFrames and ...
... EmbeddedObjectFrames in Writer

Bisected with: bibisect-43max

Adding Cc: to Armin Le Grand
Comment 5 Justin L 2018-11-28 08:44:03 UTC
Created attachment 147085 [details]
tdf116071_paraStyleBackground.odt: area color kept, but not changeable via UI in .doc format
Comment 6 Justin L 2018-11-28 17:29:49 UTC
Since Armin has apparently abandoned following up on his changes, and there are very many bugs related to it, I'm rather cautious about tackling any of this because it is probably a lot more complex that I can imagine. So, I'm not taking this bug, but here is a patch that works for me. I want to do a lot more investigation before I commit it though. https://gerrit.libreoffice.org/#/c/64186/
Comment 7 Commit Notification 2019-01-15 18:52:02 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3539a1efb41a787237e4333ebc715db96ffacb5b%5E%21

tdf#116071 ww8import: import to XATTR_FILL instead of RES_BACKGROUND

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-01-16 15:39:33 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 1bf68dbf53f4b5308e295058226abd6d6fb49c3d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Justin Luth, thanks for fixing this!!

Cherry-picked to 6-2 -> https://gerrit.libreoffice.org/#/c/66465/
Comment 9 Commit Notification 2019-02-05 09:32:23 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/026c685ab480e2afd6cbbbd82d02afde643669f0%5E%21

tdf#116071 ww8import: import to XATTR_FILL instead of RES_BACKGROUND

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-11-09 10:28:49 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5f0844077d289a257b914f0aad9fd93788f34511

partial revert tdf#116071 import to XATTR_FILL not RES_BACKGROUND

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-11-09 14:59:48 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/bf7894c4af3023f77a53427d756d8ccba2f0ac6e

partial revert tdf#116071 import to XATTR_FILL not RES_BACKGROUND

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.